Support » Plugin: WP-Click-Tracker » I cant acces the plugin "You do not have sufficient permissions"

Viewing 10 replies - 1 through 10 (of 10 total)
  • I just started with this plugin today and I’ve been getting the same alert message.

    Any suggestions in how this can be fix?

    R. Miguel

    Same issue here…

    WP: 3.5.1
    WP-CT: 0.7.3

    This happened after I updated both WP & WP-CT.


    I am having the same problem. But I installed this about 2 years ago, and I haven’t logged in for quite some time. I just tried today, using the Administrator’s username and password, and I’m getting the same error message of “You do not have sufficient permissions to edit the links for this blog.”

    Any advice on how to get past this? Using WP 3.5.1

    Have anybody had any luck with this as I installed the plugin today and it does the same thing


    It would be nice, with so many people reporting this issue, if the developer could help out. Hope we get some help soon or I might as well delete the plugin and find another solution. (Sad)


    @deonmeyer, I agree! Except I already when ahead and delated the plugin. My thoughts are… that maybe the developer has lost interest or passion for this project. 🙁

    Found a fix that worked for me… Install the plug-in called “Link Manager,” activate it, and your “WP-Click-Tracker” should work again (assuming your user has rights to manage links.) This worked for me, hope it works for you too!

    Link Manger:

    Take care,



    You know .. while this fix you found which may very well work, and all I can say is “Thank you” for figuring something out … all I can say (for me) is .. if the developer of WP Click Tracker isn’t going to support his plugin and fix something like this, I’d prefer to either just remove it or find something else to use. I just don’t feel comfortable using any plugin that isn’t supported (for at least required fixes) by the developer. So, it makes me nervous to keep using it .. and to install and add “another” plugin .. to fix a different one. LOL Thanks .. but for me, I am either going to wait for the developer to fix this, or not use the Click Tracker plugin (as I’ve already removed it from my sites until it’s fixed.)

    But again, I really did appreciate your post with the recommended fix.

    Gary Gordon

    After reviewing this issue further, I found that there was a two line section in one of these files that could be the root of the issue. In the folder path of: wp-content/plugins/wp-click-track there is a file called In that file, there are a couple of lines like the following:

    if (!current_user_can('manage_links'))
    wp_die(__("You do not have sufficient permissions to edit the links for this blog."));

    This is on line 122 & 123 (for my version of 0.7.3.) I simply commented out those two lines by adding two forward slashes and the plugin started working, without the “Link Manager” plugin being added.

    So in replace:

    if (!current_user_can('manage_links'))
    wp_die(__("You do not have sufficient permissions to edit the links for this blog."));


    // if (!current_user_can('manage_links'))
    // wp_die(__("You do not have sufficient permissions to edit the links for this blog."));

    Again, I am NOT the developer but this worked for me. Use at your own risk; I have no known knowledge of what ramifications this may cause. From what I can tell, however, is that the “Link Manager” is a feature that used to be built into WordPress, but has since been retired. Hopefully the developer can comment as to whether this is a viable solution or not. But for now, I’m going to continue with this and just monitor this for any issues. So far, it’s working fine on a site with a good amount of traffic.

    @garymgordon – I understand your position and frustration… But this is a free plugin; not one that you had to pay for – so to expect the same support as a premium plugin I feel is unjust. WordPress is driven by community helping one another out, same goes for these plugins I feel. We really don’t know what the situation with the developer is. Maybe they lost interest (which would be sad, you’re right). But then again, maybe they’re dealing with some personal issue right now and not able to dedicate any free time to this plugin. Maybe their just busy with their actual job. We don’t know. I just don’t feel it’s right to criticize the developer for not fixing this right away. A little patience goes a long way… Hope you understand where I’m coming from.

    Marvelous thanks Daniel981 thats fixed for me 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘I cant acces the plugin "You do not have sufficient permissions"’ is closed to new replies.