Support » Plugin: WP Mail SMTP by WPForms » I can not set From Name when I use gmail WP Mail SMTP

  • Resolved cinciali

    (@cinciali)


    I can not set “From Name” when I use gmail for WP Mail SMTP. Sender name always appear my gmail mail adress. For example my email is abcd@gmail.com, then Sender name appears as abcd while I set From Name as XYZ.

    How can I solve this?

Viewing 15 replies - 16 through 30 (of 42 total)
  • Hi, this helped me:

    https://wordpress.org/support/topic/i-can-not-set-from-name-when-i-use-gmail-wp-mail-smtp/

    – Check the Under Misc tab in plugin admin area.
    – Uninstall WP Mail SMTP
    – Remove plugin and re-install

    Did this ever get addressed? I’m here more than a year later with the same problem still…

    Plugin Support Jess Quig

    (@jquigam)

    Hi Manly,

    If you’ve updated to the most recent version of WP Mail SMTP, then you should be able to edit the From Name (under WP Mail SMTP > Settings).

    This will work just fine in the wide majority of cases. However, there are some specific situations (for example, certain local site setups) where Google will not accept custom From Names.

    However, either way this behavior is a result of limitations within Google’s API — not a product of the way that WP Mail SMTP handles these settings (we’d definitely prefer to let everyone customize these settings however they’d like, if that wouldn’t negatively impact email delivery).

    If adjusting the From Name for various forms, etc on your site is important, then I would strongly recommend switching to a different, and more flexible, mailer option. As long as you have a domain-specific email address (ie example@yourdomain.com), I’d specifically recommend either Mailgun or SendGrid — both of these mailers use DNS records to authenticate your emails, and so are tied to your domain rather than one specific email account. This will allow you to use any From Names you’d like, and also different From Emails (so long as those From Emails are all ___@yourdomain.com).

    I hope this helps! 🙂

    Was this fixed in the latest release 1.5.2?

    This seems to not work.
    1.5.0 – 2019-07-09
    Changed: Gmail mailer – allow to change From Name email header.

    “Force From Name” has added but its not working.
    Version 1.6.2

    Setting this up for Gmail with “other smtp” doesn’t seem to work at all. Settings are correct on my end but the test emails aren’t sending.

    Google Smtp setting:
    Outgoing Mail (SMTP) Server: smtp.gmail.com
    Use Authentication: Yes
    Use Secure Connection: Yes (TLS or SSL depending on your mail client/website SMTP plugin)
    Username: your Gmail account (e.g. user@gmail.com)
    Password: your Gmail password
    Port: 465 (SSL required) or 587 (TLS required)

    I’m just trying to set this up for my client and I don’t want the submitted emails to say they are from me.

    Anyone else having these issues?

    Thanks all,
    Sol

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi,

    Yes, the custom ‘From Name’ is allowed since version 1.5.0, but depending upon some DNS records, google server can’t connect to the domain to utilize the ‘From name’ in the settings and so uses everything from google account. We are giving a thought about this in our future updates.

    @soloant, When you are setting up SMTP with an account, you’re sending the emails from that account. There is no way to set up SMTP with an account and send emails from another account. This isn’t an issue but a default behavior.

    I hope this helps!

    it seems like in addition something else is going on because i don’t even think the name from the google account is being used .. for example if my google account settings are
    "My Name" blar@gmail.com

    my emails are coming from “blar” (“My Name” never gets used)

    • This reply was modified 1 year, 2 months ago by locomo.
    • This reply was modified 1 year, 2 months ago by locomo.
    • This reply was modified 1 year, 2 months ago by locomo.

    Using Google SMTP, I have tried multiple methods but none work.

    1. Set From Name in Gmail settings
    2. Set From Name using wp filter and hard coding
    3. Set From Name in woocommerce email settings
    4. Set From Name in WP MAIL SMTP

    The From Name works in Email Test for WP MAIL SMTP. It will show My Site <noreply@mysite.com>

    The From Name FAILS for emails sent from woocommerce orders. It displays the name of the email address ‘noreply’ in this case.

    So it looks like the Google API does give permission. So what is going on?

    Am also facing same problem. Is it resolved for anyone. Please comment solution. Am sending from support@domain.com, so its shows from name as support, actually i want to show my domain name in the case of mail from name.Please help if someone find solution

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    I apologize for any confusion. Gmail API does give permission to override the ‘From Name’, but depending upon some DNS configuration, under certain circumstances, it takes ‘From Name’ as a part of your google account email address.

    @ovatiq, however, the behaviour should be the same for the test email and WooCommerce order emails. Could you please confirm the different behaviour under same domain?

    Thanks!

    fit-nerdy

    (@gabypolancoa)

    This is happening to me too.

    I’ve been emailing support@wpforms.com asking for help. In fact, I have even asked if buying one of theirs paid plans would solve this problem.

    I really like WP Forms and I’ve set up my whole website with it, but does anyone know another SMTP plugin besides the WP Mail SMTP? One that actually works!

    Thank you.

    ps: Not sure why this forum is labeled as “Resolved” when it’s not.

    debover

    (@debover)

    I posted the below comment on this thread 1 year 2 months ago:

    I don’t know if this will work for you but I found a workaround that works for me. After a crazy amount of time trying to get the WP MAIL SMTP plugin and other similar plugins to work the way I needed, I ditched the SMTP completely. Using just the WPFORMS plugin, somehow I discovered that if I did the following things, emails from the contact form on my website get labeled in a way that works for me and also get delivered immediately in the Gmail inbox instead of going to spam with no scary warnings.

    1. Through CPanel set up an email address such as “contact-form@websitename.com”
    2. Also, through CPanel set up a forwarder from “contact-form@websitename.com” to a Gmail address
    3. On the Notifications page in the WPFORMS plugin, set the “Send To Email Address” the same as the “From Address”. I did not use code; I just put in the email address: contact-form@websitename.com.

    I hope this works for you and anyone else struggling with this issue.

    lienkhuong

    (@lienkhuong)

    Same problem but i solved

    view image: https://imgur.com/bA4V0u0

    • This reply was modified 7 months ago by lienkhuong.

    “From Email” And Gmail authenticator email should be same.

    “From Email” is disabled

    *If you are dev just modify HTML and change the disabled settings*

    Worked for me

Viewing 15 replies - 16 through 30 (of 42 total)
  • You must be logged in to reply to this topic.