WordPress.org

Support

Support » How-To and Troubleshooting » I can not have unmoderatted comments

I can not have unmoderatted comments

  • Hi:

    Every comment the blog has, goes to my email to approve… why ?

    In Options -> Discussion
    -> “Allow people to post comments on the article” is CHECKED
    -> “An administrator must approve the comment (regardless of any matches below)” is UNCHECKED

    In every post i write “Allow comments” is CHECKED

    what is wrong ?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Check the max. number of links for comments to get moderated. It should not be set to zero, because then every comment has to be moderated (as far as I understood it).

    It’s set to 2

    Is there any spam-plugin installed and activated ?

    Maybe a look into the following page might help:

    http://codex.wordpress.org/Combating_Comment_Spam

    It’s a description on how to get rid of Sspam, but there’s also one topic “Why is every comment going into the moderation queue?”. Maybe it helps.

    I have read carefully
    http://codex.wordpress.org/Combating_Comment_Spam/FAQ#Why_is_every_comment_going_into_the_moderation_queue.3F

    – I have NO characters in SpamBox
    – The number of links is 2
    – “Allow people to post comments on the article” is CHECKED
    – “An administrator must approve the comment (regardless of any matches below)” is UNCHECKED

    and i get all the comments in awaiting approval 😛

    help!

    Which version of WordPress do you use ???

    And are there any plugins activated ?

    1.5.2 installed 87 days ago

    Yes, i have a lot of plugins:
    Useronline
    time2read
    SimpleTags
    Google Analytics
    WP-RSS-Import
    LiveCalendar
    ItHappenedHere!
    Flickr Related Images
    FAlbum
    WeatherIcon

    These plugins shouldn’t have sideeffects on the comments, but to make it sure: Try deactivating all of them and then have a look at the comment problem.

    If that won’t work, have a look into the database, if the options are set there correctly (maybe a strange caching problem).

    nothing yet…
    every plugin deactivated, and comments still being moderated 😛

    I have checked step by step ALL options mysql table with another blog that has no problem with comments… Everything is the same…

    agh !

    Please, can anyone help me ?
    I have compared two wordpress options database table.
    It’s the same!!!

    but i have to moderate all comments !
    why ?

    Moderator James Huff

    @macmanx

    Support Team Rep.

    You say that you have no characters in the moderation list, but check it very carefully for “invisible” characters. A blank line or single space tends to be the most frequent cause of this problem.

    It’s completely empty… it’s the first thing I saw…

    Anyway, except the blog name, blog url and directories, the options tables of 2 blogs are exactly the same !!!

    One have all comments unmoderated
    And I have to eat with ’em! 😛

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘I can not have unmoderatted comments’ is closed to new replies.