WordPress.org

Support

Support » How-To and Troubleshooting » I can no longer update ANYTHING – due to enable sending referrers thing (2.0.3)

I can no longer update ANYTHING – due to enable sending referrers thing (2.0.3)

  • I spent all day building a WP site. It was located at www.”servername”.com/”subdirectory”

    I then registered a domain name at Godaddy and did a mask forward to that servername/directory path.

    I then changed my WP admin settings to make the site and blog address the new domain name rather than the servername/directory path.

    Now, it looks like the stylesheet for my site is not longer being applied and if I go in to make any changes at all, I find that I can not – I can do nothing in the admin panel. Whatever I do gives me a “Sorry, you need to enable sending referrers for this feature to work.” error when I hit update. I can’t change it back to the server path or anything.

    I’ve looked all over the net for a solution. I’m using no firewalls, security, etc. I’m on 2.0.3 for which the check_admin in the admin_functions.php is no longer there, etc. It seems all is lost… is there any help on this?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Can you get to Options -> General ?

    Do you have the right values for the top two URI fields?

    Yes – correct entries (it is the new registered domain name) but even if I wanted to change it back, I can’t now – I can’t do ANYTHING without getting that error.

    OK – I went to my PHP Admin and I Dropped one table at a time – dropping users made it work again.

    Now, I’m still left with a weird problem. Everything seems to work except I can not delete any blogroll links. What could be going on here?

    well, missing tables will certainly be a problem in the long-run.

    Assuming you have all your tables, you should consider an upgrade to 2.0.4 for security purposes. If you stay with 2.0.3, you should grab this tuneup plugin that may help: http://txfx.net/code/wordpress/wordpress-203-tuneup/

    It wasn’t missing table – I don’t know what the problem was. I dropped tables because I ran across someone else who had this problem and he said in his post that while he never got an explanation on why it happened, he did see that changing the address of his blog messed up his database tables. He dropped his tables and it worked for him.

    All he did and all I did to cause this apparent bug was change the name of our blog in Options.

    Weird, eh?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘I can no longer update ANYTHING – due to enable sending referrers thing (2.0.3)’ is closed to new replies.
Skip to toolbar