Support » Fixing WordPress » I can no longer save, edit or delete posts

  • Resolved phdotaschauer



    Since I posted my last entry, I can no longer save, edit or delete a post. Besides, I can’t create a new one or try to save it (as unpublished). I don’t really know what this is all about, so I came to you guys.

    I tried to switch off all my plugins. I figured it might be the reason of the malfunctioning of the system. Well, that obviously wasn’t the problem either.

    I do not get an php error, no mysql error, it is just refreshing the page and it disappears (when writing a new post) or if I try to delete the draft I want to get rid off, then it also just refreshes, but it is still here.

    BTW (I dont know if that is in direct context) my WYSIWYG Editor isn’t working properly anymore either. It seems like the paragraph problem from WordPress 2.3 is back (I am using Safari – on a Mac).

    I want my wordpress to work again, so I’ll do pretty much anything you guys suggest.

    Thank you. Do you need more information? My blog is


Viewing 3 replies - 1 through 3 (of 3 total)
  • BTW, I already posted new entries on wordpress 2.5 and it worked!

    SQL query:

    SHOW FIELDS FROM wp_posts ;

    MySQL said:

    #1016 – Can’t open file: ‘wp_posts.MYI’. (errno: 145)

    This is the error I get when I want to open wp_posts in my mysql admin system 🙁
    Seems like something’s broken there!

    Do you guys think this was caused by the wordpress software? my wp_post database was hurt. luckily i had a backup!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘I can no longer save, edit or delete posts’ is closed to new replies.