Support » Plugin: Simple Facebook Connect » I can no longer post to Facebook f

  • Resolved ellensmith


    This application worked fine for me for a couple of years. I posted to Facebook both manually and automatically, I enabled Facebook login for my blog, and I had Facebook comments post to my blog.

    Now, apparently due to Facebook’s changes, I can no longer post from this app to Facebook. I see the error message “The post’s links must direct to the application’s connect or canvas URL.” I have tried uninstalling and reinstalling this app, but the results haven’t changed.

    In early February, Facebook gave me a list of about 7 things that had to be made compliant for “my app” to continue working. I finally clicked the boxes saying “fix now”, which caused everything to be deemed compliant, even though I didn’t know what I was agreeing to. It continues to tell me that I have not enabled February 3 “breaking changes” and tells me to “Please confirm Ellen Smith for Oak Ridge blog is compliant by February 5, 2013”. When I click “Fix now” for that item, it tells me “Your app, Ellen Smith for Oak Ridge blog, has not enabled the migration for the February 2013 Breaking Changes.
    Once you have confirmed your app is compliant or unaffected by the February 2013 Breaking Changes, set the migration setting to “Enabled” in the Advanced section of the App Dashboard. This will apply the February 2013 Breaking Changes to your app and prevent you from receiving future alerts about these changes.” I would gladly do that, except that the FB “App Dashboard” doesn’t have a place to set “Enabled” for February breaking changes (I’ve successfully set “enabled” for March and April, though).

    Any advice on what to do?

    Facebook has given me a blizzard of messages about my app needing to be made compliant with their new system. Since I never developed an app, I’m rather clueless about their messages. The most comprehensible one is “Your app detail page has not yet been submitted for review”, but that doesn’t make much sense because all I really want to do is publish my blog posts to my FB profile. When I hit the button to “submit app detail page” for review, it tells me:

    Missing Information
    Your submission is missing data in the following fields:

    Detailed Description
    Privacy Policy URL
    Image: 128 x 128
    Image: Web Banner
    Show all (7)

    I also see messages like “You have not generated a URL through one of our partners”, but I have no interest in FB’s partners.

Viewing 4 replies - 1 through 4 (of 4 total)
  • At the Facebook support forum on Stack Overflow (the closest thing that Facebook suggests as a help page for this issue), I got the advice that “… Facebook has disabled the importing of external feeds long time ago.” It appears, however, that other people are still successfully using Simple Facebook Connect for this purpose.

    Plugin Author Samuel Wood (Otto)


    Quick fix for the “The post’s links must direct to the application’s connect or canvas URL” problem:

    1. Go to your facebook application:
    2. Edit the settings for the app, and go to the “Advanced” settings page.
    3. Find “Stream post URL security” and set it to “Disabled”.

    Plugin Author Samuel Wood (Otto)


    Also, don’t worry about all their “breaking changes” stuff and so forth. SFC is not affected by any of those and you can safely ignore it. You also don’t need to submit the app for review or any of that jazz.

    Facebook’s Application system is an all-in-one system, meaning that it has lots of stuff you probably won’t be using for your needs.

    Thanks! That solved the problem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘I can no longer post to Facebook f’ is closed to new replies.