Support » Fixing WordPress » I can no longer make links

  • I can no longer make links on my website,

    Previously this was easy to do. Step one highlight the text, step two hit the Link button, step three enter the appropriate url, step four, update the page. Viola, text turns blue and is a link.

    Now, when I click on the link button when editing the page, nothing happens. Nothing at all.

    I have tried this in Chrome, Firefox and Explorer. Nothing.

    I wrote Blue host.

    I explained that this problem was occurring BEFORE uploading the latest version of Word Press and continues now.

    Below is the text of the email I received from Blue host technical support. I include it here because frankly I have no idea what the hell it means, and I could not remotely hope to reproduce it in my own words.

    date Fri, Jul 15, 2011 at 6:20 PM
    subject Re: [#CAS-63180-315] Contact me: Other
    Important mainly because it was sent directly to you.
    hide details 6:20 PM (1 hour ago)
    I’ve tracked down where the problem appears to be occurring. It’s due to it missing a single quote somewhere where the variable ajaxurl is defined. here’s the error:

    unterminated string literal
    ajaxurl = ‘

    As you notice, that’s missing a “‘” on the end that terminates that string. That’s breaking the ajax functionality (javascript that lets you click on your link button and have them show up correctly). I looked through the code and am seeing ajaxurl being defined in multiple locations and am not finding the case where it’s missing the quote.

    I’m sorry, but this is outside the scope of our technical support. For more help with WordPress specific issues, I would recommend visiting: Someone there should be able to help you track down where that quote is missing and whenever you find it and add it, that should resolve the problem.

    Thank you,
    Level II Scripting/Site Compatibility Engineer
    – END quoted text -“

    I am sadly, a novice. Any explanations of what to do will need to be pitched to me as real slow balls. If I can’t resolve this I will have to re-create all my pages from scratch. Sites where I cannot make new links are basically worthless.

    In short,



Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator kmessinger


    Have you tried:

    – deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Don’t forget the ones in mu-plugins. If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.


    I will do so, but I have so few, and the ones I have, I already had before there was a problem.

    But, I will do so and see what happens.

    Sadly, deactivating the plug ins has had no impact on my ability to create new links.

    Just to test, try installing a new WordPress in a test folder. See if you can add links in it.

    If you have used copy/paste into any of your existing pages, and pasted from Microsoft Word, or from content copied from a website, you may have unintentionally brought along some extra unintended code which is breaking things. Word is especially infamous for throwing in extra junk.

    If you are aware of such things happening, you may want to remove those posts and see if that fixes it. Before doing so, use the Export feature to get a backup of your database.

    If the test site you installed worked, try importing that exported content into it and see what happens. If it breaks the test install, then you know that one of your posts/pages is breaking it. If it does not break it, then something with your actual WordPress content is breaking it.

    If it does not break the test install, then you can try switching your theme on the main, and/or installing the main again and importing your content into it.

    As always, make sure you have a backup.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘I can no longer make links’ is closed to new replies.