Support » Plugin: WP Datepicker » I am not able to show the calendar on the text field

  • Resolved d_alinus2004

    (@d_alinus2004)


    Hello,

    I have add this short code on the contact form7 :
    [text your-dt class:dp-field]

    Then on the data piker settings i have add:
    #dp-field, input[type=’text’][name=’your-dt’]

    But not work..:(
    Whta’s wrong with my code ?

Viewing 2 replies - 16 through 17 (of 17 total)
  • Thread Starter d_alinus2004

    (@d_alinus2004)

    @fahadmahmood Many thank’s for your positiv reponse…:)

    Just to resume, i have put the next code on the WP Datepicker- Settings

    #datepicker, .hasDatepicker, .dt-field-1, .dt-field-2

    On Cotact form i have put the next shortcode:
    field1: [text your-dt class:dt-field-2]
    field2: [text your-dt1 class:dt-field-1]

    I confirm you that’s work like that!
    And also work the placeholder …:)!!
    Many regards and many thank’s for you help.

    Because

    Plugin Author Fahad Mahmood

    (@fahadmahmood)

    @d_alinus2004 i have reservations about.hasDatepicker because this class normally assigned to the fields which have a datepicker instance already. Same with #datepicker. We should avoid all the classes and IDs which can confuse us with the selector “datepicker”. You got it working because this plugin destroys the previous settings first and then initialize for the new datepicker instance.

Viewing 2 replies - 16 through 17 (of 17 total)
  • The topic ‘I am not able to show the calendar on the text field’ is closed to new replies.