I am having trouble importing a TextPattern blog (8 posts)

  1. lkrubner
    Posted 8 years ago #

    I'm helping a client move their site to a new web server. They had a TextPattern weblog that we are now trying to make a WordPress weblog. I moved the database and files for TextPattern, but there is some kind of problem:


    I read this tutorial:


    It did not work for me.

    I'm trying to get info into this WordPress installation (which now seems to be broken itself).


    Feeling a little lost. I've never worked with TextPattern before. Any advice?

  2. lkrubner
    Posted 8 years ago #

    I'm happy to send anyone $50 if you can fix this problem for me.

  3. lkrubner
    Posted 8 years ago #

    How about $100?

  4. stickwithjosh
    Posted 8 years ago #

    I'm also having some difficulty importing a textpattern blog. I'm guessing the textpattern script isn't doing any error handling because even putting in bogus information to test turns up no errors and "0 categories found" instead of content.

    I'll post here as I debug and try to find a solution.

  5. stickwithjosh
    Posted 8 years ago #

    Ok, I was able to get this working fairly easy, I was just using the wrong database settings. Looks like you also want to import your data into the wp database to make things work as well. Some basic DIE statements should be added to the script, but I'm guessing it hasn't been a problem, since I've only seen a few mentions of this around.

  6. poocat
    Posted 8 years ago #

    Hi, do you have a better version of the script? I am trying to import, I have the Textpattern setup in a separate database (same host) as the WordPress install. I know this is an old question but I can't figure out what is wrong with my settings.

    I am getting the following error:

    `Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /wordpress/wp-admin/import/textpattern.php on line 734

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /wordpress/wp-admin/import/textpattern.php on line 734
    No Categories to Import!`

    I am running the script off of Alex Brie's site, rather than the default one. If I run the default one I get the same as you, no errors and just "0 categories found".

    Thanks in advance for any help.

  7. stickwithjosh
    Posted 8 years ago #

    I got similar errors, what I had to do was export the textpattern database into the same database that wordpress was using, shouldn't be a problem because you probably have wp_ and txp_ prefixes on all of the tables.

  8. Anonymous
    Posted 7 years ago #

    I have tried a whole slew of Database settings and I am still getting the same "0 categories found" error. What did you finally have to use to get it to see the information?

Topic Closed

This topic has been closed to new replies.

About this Topic