Support » Plugin: Pronamic Pay » I am getting this error field generating error : Signature

  • Resolved Joeri

    (@joeri1977)


    Hi,

    This topic was also started by someone else but the replies are not helping me resolving this issue. I keep getting the error message:

    Authentication error. Field generating error: Signature

    I am using Rabobank iDeal Professional V3.

    Can someone help me out!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Reüel van der Steege

    (@pronamic_reuel)

    Did you upload the certificate which is generated when you save the configuration (WordPress dashboard » Pay » Configurations) to the corresponding test/live Rabobank dashboard?

    Also see https://www.pronamic.nl/support/pronamic-ideal-koppelen-met-rabobank-ideal-professional-v3/ detailed instructions (in Dutch).

    Joeri

    (@joeri1977)

    Yes, I did. At first everything was auto generated so I downloaded the certificate but within the Rabobank dashboard I got an error… something regarding sha256.

    So next I generated a key and certificate following the (Mac) instructions, uploaded this and used the ‘download certificate’ button again. This time the certificate was accepted within the Rabobank dashboard but within WordPress I got the error message: Authentication error. Field generating error: Signature.

    Once more I removed the private key and certificate field and auto generated new ones. Downloaded and uploaded the certifacte again with no errors but still the error message is there within WordPress.

    It’s therefore (I think) not possible for me to do the test payments.

    Plugin Author Reüel van der Steege

    (@pronamic_reuel)

    > It’s therefore (I think) not possible for me to do the test payments.

    That is correct, authentication needs to be set up correctly before being able to make (test) payments.

    Just to make sure, the “mode” for the configuration in WordPress is set to “test” and you’re uploading the certificate to the test dashboard (https://idealtest.rabobank.nl/) too? The fingerprint mentioned below the certificate input field in the configuration should be listed in the overview of uploaded certificates in the iDEAL test dashboard. If it is, I’d suggest contacting Rabobank to verify that the iDEAL test account is ready for use.

    Joeri

    (@joeri1977)

    Well………. that’s what you get when you don’t read, or misread, the manual! I didn’t know about the idealtest.rabobank.nl environment. I thought everything was setup in the ideal.rabobank.nl dashboard.

    Uploading the certificate to the test environment solved the issue!

    Thank you very much!

    Plugin Author Reüel van der Steege

    (@pronamic_reuel)

    Glad to hear you were able to resolve the issue!

    After the test payments are performed with the test environment, within +/- 2 business days Rabobank will activate the live environment (which needs the certificate too, but you’ve already set that up 😉 ). So, once the account is activated and you switch the configuration to live mode, everything should work as expected.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘I am getting this error field generating error : Signature’ is closed to new replies.