Support » Plugin: Secure Downloads » I am getting fatal error

  • Fatal error: Uncaught Error: [] operator not supported for strings in C:\xampp\htdocs\Stayinfront\wp-content\plugins\secure-downloads\core\admin\api-settings.php:552 Stack trace: #0 C:\xampp\htdocs\Stayinfront\wp-content\plugins\secure-downloads\core\any\class-admin-settings-api.php(88): OPSD_Settings_API_General->init_settings_fields() #1 C:\xampp\htdocs\Stayinfront\wp-content\plugins\secure-downloads\core\admin\api-settings.php(35): OPSD_Settings_API->__construct(‘set_gen’, Array) #2 C:\xampp\htdocs\Stayinfront\wp-content\plugins\secure-downloads\core\admin\page-settings.php(37): OPSD_Settings_API_General->__construct() #3 C:\xampp\htdocs\Stayinfront\wp-content\plugins\secure-downloads\core\admin\page-settings.php(123): OPSD_Page_SettingsGeneral->settings_api() #4 C:\xampp\htdocs\Stayinfront\wp-content\plugins\secure-downloads\core\any\class-admin-page-structure.php(223): OPSD_Page_SettingsGeneral->content() #5 C:\xampp\htdocs\Stayinfront\wp-includes\class-wp-hook.php(286): OPSD_Page_Structure->content_structure(‘opsd-s in C:\xampp\htdocs\Stayinfront\wp-content\plugins\secure-downloads\core\admin\api-settings.php on line 552

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    Yes, its seems like a mistake there.
    Please make this fix (its will be exist in the next update of plugin).
    Please open this file ../wp-content/plugins/secure-downloads/core/admin/api-settings.php

    ( you can check how to edit files in WordPress menu in this article https://wpbookingcalendar.com/faq/how-edit-file-in-wp-menu/ )

    then find this code:

    
    			$this->fields['help_plugin_system_info'] = array(   
    							   'type'              => 'help'
    							 , 'value'             => ''
    

    and replace it to this code:

    
    			$this->fields['help_plugin_system_info'] = array(   
    							   'type'              => 'help'
    							 , 'value'             => array()
    

    Kind Regards.

    • This reply was modified 1 year, 8 months ago by wpdevelop.

    Thank you so much. It resolved my issue.

    Kind Regards,
    Hardik

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘I am getting fatal error’ is closed to new replies.