Support » Fixing WordPress » I am getting a warning message I dont understand

  • When I try to update a plugin or widget I get this….

    Warning: Cannot modify header information – headers already sent by (output started at /home/dougkpga/public_html/wp-content/themes/NicheProfitPressV2/functions.php:16) in /home/dougkpga/public_html/wp-includes/pluggable.php on line 865

    can anyone help please?

Viewing 3 replies - 1 through 3 (of 3 total)
  • whooami

    (@whooami)

    Member

    you have whitespace before or after your opening or closing php tags inside /home/dougkpga/public_html/wp-content/themes/NicheProfitPressV2/functions.php

    based on the line number, after the closing ?>

    ok i am new this but ill check it out.

    Thanks for your help

    This is my code in the functions.php

    <?php
    /**
    * @package WordPress
    * @subpackage Classic_Theme
    */
    if ( function_exists(‘register_sidebar’) )
    register_sidebar(array(
    ‘before_widget’ => ‘<li id=”%1$s” class=”widget %2$s”>’,
    ‘after_widget’ => ”,
    ‘before_title’ => ”,
    ‘after_title’ => ”,
    ));

    ?>

    I have deleted everything after the closing tag.

    when i update it edited successfully – thanks again – ii hope it helps someone else…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘I am getting a warning message I dont understand’ is closed to new replies.