Support » Plugin: Hustle - Email Marketing, Lead Generation, Optins, Popups » Hustle pop-up not showing, even in preview

  • Resolved ik74


    Struggling to have my first Hustle pop-up show up on the website. Even the preview is not showing up, not able to see how the pop-up will look.

    Have tried to deactivate all plugins, leaving only Hustle. Still, get the same result.

    Is this a common problem? What am I doing wrong?

    Thanks much in advance!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Zafer – WPMU DEV Support


    Hi @ik74,

    I hope you are doing well today!

    Please check if you have published the popup from the blue PUBLISH button at the top right and the Visibility and Behavior settings are correct for you. By default, your pop-up is set to appear everywhere on your website.

    Some useful blog posts with tutorials

    If above information did not help, please share an export of the popup which will help us to check the issue further.

    You can export it from Edit section :

    After exporting, please share the contents of the json file using a service such as which is free to use. You can also share the json file itself by services like Google drive.

    Please always make sure to use such service to share the code and don’t post the code here directly as it will most likely be unusable.

    Kind regards,

    Thread Starter ik74


    Hello @wpmudevsupport15 , thank you for your hints.
    I have tried, but looks like I am still not managing through.
    Could be something stupid, but doesn’t seem to work for me.
    Here is the Google Drive link to the JSON file.

    Thank you in advance!

    Plugin Support Adam – WPMU DEV Support


    Hi @ik74

    Do I correctly understand that you want to show popup just “everywhere”?

    If yes, please try removing all the visibility rules from “Visibility” settings, then update the popup (make sure it’s published), clear all cache and test again.

    If you want to limit where it shows later – we can get back to it but first, please test if it works with all the visibility conditions removed.

    Give it a try, please, and let us know about result here.

    Best regards,

    Thread Starter ik74


    Hello Adam @wpmudev-support8 ,

    Thank you.

    To start with, just wanted to see a preview of the pop-up – to test and set it up.
    And yes, wanted it to show everywhere – the most simple way.

    Have removed all visibility settings (, cleared cache, tried it Chrome and Edge, still not visible – no preview either.

    Do you need an updated JSON file?

    Thank you!

    Plugin Support Adam – WPMU DEV Support


    Hi @ik74

    Thanks for response and I’m sorry for missing the part about preview.

    If you can’t even see the preview, there must be some additional issue there.

    I understand that you tried to deactivate other plugins and it didn’t change anything. Did you also try to temporarily switch active theme to Twenty Twenty-Two or Twenty Twenty-Three?

    If not, please try it (just to test).

    Also, please do this:

    – open browser console (CTRL+SHIFT+I in Chrome on PC, should be similar with other browsers too)
    – then try to open popup preview
    – and see if there are any errors reported in browser console

    If there are, please share those errors with us here.

    Kind regards,

    Thread Starter ik74


    Hello Adam, thank you for your help. @wpmudev-support8

    Yes, temporarily switching to Twenty Twenty-Three has worked. The preview started to show up.

    Yes, there seem to be loading warnings in the browser console. Here they are:

    JQMIGRATE: Migrate is installed, version 3.3.2
    [Elastic APM] Failed sending events! Error: HTTP status: 0
        at e._constructError (elastic-apm-rum.umd.min.js:1:25909)
        at elastic-apm-rum.umd.min.js:1:24711
    levels.forEach.t.<computed> @ elastic-apm-rum.umd.min.js:1
    (anonymous) @ elastic-apm-rum.umd.min.js:1
    DevTools failed to load source map: Could not load content for HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

    Thanks a lot!

    Plugin Support Nithin – WPMU DEV Support


    Hi @ik74,

    I’m afraid the console errors don’t help much. It’s pointing to an elastic APM JS file. Is there any plugin or service that uses Elastic APM or AWS? Or any plugins related to AWS?

    If yes, please check whether you notice any difference if it’s temporarily deactivated. Or does the theme has any such feature?

    However, if the popup works fine with all plugins deactivated and only with a default WP theme, and the issue occurs once the current theme is activated, then I’m afraid the issue would be more related to the theme.

    When checked, it seems to be a premium theme, so what we could test or comment on causing the issue is limited.

    Would highly recommend bringing this to your theme support’s attention and check what they have to say regarding the issue noticed.

    Please do let us know how that goes. So that we could check further if needed.

    Best Regards,

    Thread Starter ik74


    Thank you, Nithin @wpmudev-support8 ,

    Yes, it looks like this issue is theme related.
    I will raise it with the theme’s support team, as you suggested.

    Current theme + all plugins deactivated = Hustler still did not work even in preview.
    Twenty Twenty-Three theme + all plugins active = Hustler pop-up showed up.

    How do I check this?
    “Is there any plugin or service that uses Elastic APM or AWS? Or any plugins related to AWS?”

    Thank you for your time in investigating with me! 🙂

    Thread Starter ik74


    It is working for me now. The issue was theme related and it is fixed now. Thanks a lot for your help!

    Plugin Support Patrick – WPMU DEV Support


    Hi @ik74

    I’m glad that this issue is resolved.

    If you have a moment, I would very much appreciate it if you could quickly rate our plugin. This will help us keep the plugin available for free.

    Best Regards
    Patrick Freitas

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.