Support » Plugin: Hustle Marketing, Social Share, Email Opt-in Form, and Popup Plugin » Hustle error showing “Bad Request”

  • Resolved nd89vn



    First, I relly like this plugin. But now I have a problem as below.
    I connected Hustle with sendy successfully, after fill into the form and click Submit button, the success messege not showing instead of a error messege like this

    (The info was saved in Sendy successfully, but the success messege not showing)
    Please show me how to fix it


    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Adam – WPMU DEV Support


    Hey @nd89vn,

    Hope you’re well.

    I couldn’t test it because of I don’t have Sendy license. But I am contacting with developers to ask what can cause this. I will update this thread when I have more information. Thanks for your patience!


    Thank for suporting

    Waiting for your good news!

    Plugin Support Adam – WPMU DEV Support


    Hey @nd89vn,

    Hope you’re well.

    I checked the Sendy integration and it works as expected. So there can be some plugin conflict. Can you try plugin conflict test and theme conflict test? You just need to try only with Hustle plugin and default Twenty Seventeen theme. Please let me know the results.



    Thank for suport, I tried to turn off all my plugin, and use default Twenty Seventeen theme but the error still showing.


    Plugin Support Nastia – WPMU DEV Support


    Hello @nd89vn

    Hope you’re doing well!

    Bad Request is an error that indicates that the server was unable to process the request sent by the client due to invalid syntax. My guess would be that the Label and the Names of the fields do not match with the Sendy fields names.

    Would you please edit Opt-in, go to the Module Fields section and make sure that the Labels and the names are set to default:
    First Namefirst_name

    If the issue still persists, please enable WordPress debug, add the following code to the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Make sure that you insert these lines above /* That's all, stop editing! Happy blogging. */.

    Run a quick test to replicate the “Bad Request” error again and check the wp-content/debug.log file for errors.

    Let us know how it went!

    Kind regards,

    Thank you and your team very much!,
    I did it!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Hustle error showing “Bad Request”’ is closed to new replies.