Support » Plugin: Hustle - Pop-Ups, Slide-ins and Email Opt-ins » Hustle admin: Fatal error: Allowed memory exhausted

  • Hi WPMU,
    I have a problem with Hustle admin for a while.
    Hustle dashboard or any submenu ends with white screen as there is fatal error:
    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /nfsmnt/hosting1_2/9/0/90c758fc-430d-4abc-be6c-296031b54077/ on line 1889

    I have installed hustle for a few years, but I’m using it only time to time for some announcements. So there is no active slide-in or pop up.

    I made staging as a copy to resolve the problem, but I’ve found that it is combination of Hustle and Woocommerce.
    I’ve created a second site from scratch, with same theme and plugins. Here it is working fine.
    So my conclusion that the problem is related to some older update, what was not done correctly.
    Remove and new install of Hustle did not helped. I checked DB, and I can see some custom tables even after delete of plugin.
    Can you give me some advice how to refresh installation? Or better how to resolve the problem?

    Best regards

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Dimitris – WPMU DEV Support


    Hello there @osimiso

    Could you please try to deactivate and delete Hustle from WP admin area, then connect to your database and delete the following tables:


    Then in [YOUR_DB_PREFIX]_options, please search and remove the following records, if available:


    After doing so, re-install Hustle and let us know how that goes.

    Warm regards,

    Hi Dimitris,
    Thanks for answer.
    I did what you wrote.
    But I have white screen again.

    These are the values of option table after fresh install:
    hustle_20_migrated 1 yes
    hustle_color_index 0 yes
    hustle_database_version 3.0.5 no
    hustle_popup_migrated 1 yes

    Best regards

    Hi Dimitris,
    is there anything I can do?
    There is still the same error:
    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /nfsmnt/hosting1_2/9/0/90c758fc-430d-4abc-be6c-296031b54077/ on line 1889

    Hustle Version 6.0.5
    WooCommerce Version 3.5.2

    Best regards

    Plugin Support Nastia – WPMU DEV Support


    Hello @osimiso

    Hope you are doing well!

    This error means that there is not enough PHP memory. Please increase it by adding the following line in the wp-config.php file:
    define('WP_MEMORY_LIMIT', '256M');

    Also, please increase max_execution_time to 180 if this will not work, try 300.

    On a staging site, please try replacing all WordPress files from a fresh downloaded installation.

    Please make sure that the database upgrade from Woocommerce plugin is made.

    Another solution, please remove both plugins, Hustle and Woocommerce (export products and orders of course). Use the Plugin’s garbage Collector plugin to clean up the database from unused tables and re-install both plugins.

    Let us know how it went!

    Kind regards,



    Hi Nastia,

    thanks for answer.
    My setting are already :
    define(‘WP_MEMORY_LIMIT’, ‘256M’);
    memory_limit 256M (max)
    max_execution_time 600s (max)

    If I create staging environment from scratch all works. If it is a clone I see the error.
    The second solution to remove Woocommerce on production site is out of option. This too dangerous.

    I would like to know what part of the Hustle code runs out the memory. This could identify the conflict with woo. Is there some debugging options in Hustle?

    Best regards

    Plugin Support Dimitris – WPMU DEV Support


    Hello @osimiso,

    hope you’re doing good and please excuse our late response here.

    We don’t have any previous report about Hustle and WooCommerce causing this kind of memory exhaustion.

    In order to better troubleshoot this, it’d be easier to create a staging environment, not creating it from scratch, but duplicating files and database so the issue is still there. Please let me know if such a creation is possible.

    In order to surpass this error though, you should increase the memory limit a bit more:
    define('WP_MEMORY_LIMIT', '512M');

    Warm regards,

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.