Support » Plugin: HungryFEED » HungryFEED filter feature

  • Resolved Maria.com_Site_Owner

    (@mariacom_site_owner)


    We’re using HungryFEED v1.4.3 and have seen the feature to filter on keywords but would like to be able to filter OUT certain keywords also so that we can choose to not show irrelevant/inappropriate content. Is this possible?

    If not, it would be a really neat new feature to add. Please consider implementing this.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jason

    (@verysimple)

    Thanks for the message Maria, I have that in development and a new parameter “filter_out” will be in release 1.4.5

    Maria.com_Site_Owner

    (@mariacom_site_owner)

    Many thanks for this and the quick turn-around to include the feature. However, I’m not sure that it’s working!

    I have included a filter_out parameter in the WP page –

    [hungryfeed url=http://www.kgbdeals.co.uk/rss, template=”1″, feed_fields=””, filter_out = “smoking|lottery”, max_items=5, link_target=”_blank”]

    so, to test this, I change the words to filter out to one which was contained within a post in the feed.
    The post was still shown on my WP page so, deleted the cache (…/wp-content/cache/) and updated the cache setting in the plug in settings to 0. Both of which make no difference.
    Can you give me an idea where to look to resolve this?

    Many thanks…

    Plugin Author Jason

    (@verysimple)

    One thing to check is that you have spaces before and after the equal sign:

    filter_out = “smoking|lottery”

    The commas are not necessary for parameters either, though I don’t think they hurt anything.

    Lastly verify that you have version 1.4.5 of the plugin. I just did a test on your feed and there were no items with “smoking” in the feed but I did try filtering out other words and it seems to be ok.

    Thanks you for the reply but, I have tried this with no success.

    Interestingly, the filter_out parameter did have spaces before/after the equal sign (and did not work) whereas, the max_items parameter is limiting the number of items to 5 and it did not have the spaces.
    So, the updated page looks like this:

    [hungryfeed url=http://www.kgbdeals.co.uk/rss, template = "1" filter_out = "smoking|poker|bingo|casino|slots|lottery" max_items = 5, link_target = "_blank"]

    I can confirm that I am using v1.4.5 of the plug in

    Update:
    This seems to be a cache/refresh issue (maybe to do with our feed provider).
    Having updated the page to filter out a word from the current feed, the item did not get filtered out for an hour or so (in spite of setting the chache setting for HungryFEED to zero, clearing the cache directory and ctrl-f5 refresh on the page).

    To try to confirm this, I have now removed the word to filter out, reset the cache and expect to see the item return to the page shortly.

    Thanks once again.

    Plugin Author Jason

    (@verysimple)

    i just checked again, it seems to be the commas in your shortcode. i was able to reproduce your problem and when i removed the commas, it was fixed.

    that did lead me to a minor bug, though, max_items is applied before the filter so if you have 5 items and one gets filtered out, only 4 display on the page. i’ll have to see about fixing that in the next release.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘HungryFEED filter feature’ is closed to new replies.