Support » Plugin: Swift Performance Lite » Hundreds of Prebuild Page Cache Cron Events Using Up CPU

  • midihead

    (@midihead)


    Please see my previous post relating to this issue here:

    https://wordpress.org/support/topic/high-cpu-server-usage-due-to-hundreds-of-cron-events/

    This issue has returned for me. I again have hundreds of swift_performance_prebuild_page_cache cron events running at the same time (the Next Run column show past dates and times which are all set to Now). This was overloading the resources on the shared hosting I’m on (I received a warning from the host and they disabled my WP-cron and set up a manual cron that would run every few hours instead to temporarily mitigate the issue until I could see the cause of the high CPU usage). I have to deactivate Swift and then manually delete all of these cron events to temporarily fix the problem. If I try to delete them with the plugin active, hundreds of new cron events are automatically created to replace the old ones. Evidently, this issue was not permanently resolved before by plugin updates.

    I am running Swift Performance Lite version 2.0.10. Can we please try to isolate what is causing this issue? It is a very intermittent problem.

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Fred

    (@fredawd)

    How many pages does your site have and how many URLs are in warmup table?
    Fastest solution is to let Swift cache pages on first visit, so second visitor get served cached pages. This is how most cache plugins work.

    To achieve this, enable Optimize in background. Also, make sure you disable Optimize Prebuild Only and Prebuild Cache Automatically.

    Aother option is to cleanup your warmup table.

    Pro version has a build-in feature called Prebuild Booster which will reduce CPU usage and speed up prebuild process.

    • This reply was modified 2 weeks ago by  Fred.

    My site has a WooCommerce store with over 300 products. As a result, the site has about 430 pages or so. Usually, prebuilding doesn’t overload the server (although CPU usage is on the high side). I usually only see a single cron for prebuilding the cache but occasionally, lots of the same cron get created and run at the same time which I guess is duplicating the prebuild over and over again. While your recommendations should help to prevent the prebuilding issue from occurring due to automatic prebuilding being disabled, it doesn’t appear to be a permanent solution to the original random issue when prebuilding is active.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.