Support » Plugin: Hummingbird – Speed up, Cache, Optimize Your CSS and JS » Hummingbird Page Caching Not working on AMP Pages

  • Resolved Hrishikesh

    (@hrishikeshbharaligmailcom)


    Hi,
    I have enabled Hummingbird Pages Cache on all post types. Page Caching is working on all posts on my main website.

    While I was debugging an AMP issue, I had disabled caching by adding “\/amp/\” to the Exclusions URL strings.

    After debugging was completed, I have removed the URL string from the Exclusions list.
    But strangely, cahcing is not working on my AMP pages.
    I have cleared all Page Cache but still, it’s not working. Please help.

    Additional Info:
    This is my active Exclusions list:

    wp-.*\.php
    index\.php
    xmlrpc\.php
    sitemap(_index)?.xml(.gz)?
    [a-z0-9_-]*sitemap[a-z0-9_-]*.(xml|xsl|html)(.gz)?
    ([a-z0-9_-]*?)sitemap([a-z0-9_-]*)?.xml
    

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Anton Vanyukov

    (@vanyukov)

    @hrishikeshbharaligmailcom,

    Please enable debug log in Page Caching and check why the request is skipping cache. The log will be in wp-content/wphb-logs/ folder

    Best regards,
    Anton

    Hrishikesh

    (@hrishikeshbharaligmailcom)

    @hrishikeshbharaligmailcom,

    Please enable debug log in Page Caching and check why the request is skipping cache. The log will be in wp-content/wphb-logs/ folder

    Best regards,
    Anton

    Hello there,
    I enabled logging and following are some suspect error logs.

    [10:53:14] Do not cache page. User-Agent is empty or excluded in settings.
    [10:53:14] Loading config file.
    [10:53:14] Do not cache page. User-Agent is empty or excluded in settings.
    [10:53:29] Loading config file.
    [10:53:34] Page not cached because of active cron or ajax request.
    [10:53:34] Loading config file.
    [10:53:34] Page not cached because of active cron or ajax request.
    [10:53:38] Loading config file.

    Do I need to de-activate and re-activate the Hummingbird plugin for this feature to work? Please help

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Could you please post your User-Agent exclusion list? Also, try removing it and checking if the page is cached.

    Best regards,
    Anton

    Hrishikesh

    (@hrishikeshbharaligmailcom)

    Hi,
    This is my User-Agent exclusion list:

    wp-.*\.php
    index\.php
    xmlrpc\.php
    sitemap(_index)?.xml(.gz)?
    [a-z0-9_-]*sitemap[a-z0-9_-]*.(xml|xsl|html)(.gz)?
    ([a-z0-9_-]*?)sitemap([a-z0-9_-]*)?.xml

    Also, try removing it and checking if the page is cached.

    Can you please clarify if you’re suggesting to remove the above UA exclusion list and then try loading the AMP pages?

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @hrishikeshbharaligmailcom,

    That is the URL Strings exclusion list. The user agent list is below, and defaults to:

    bot
    is_archive
    slurp
    crawl
    spider
    Yandex

    Best regards,
    Anton

    Hrishikesh

    (@hrishikeshbharaligmailcom)

    Hi,
    Sorry, my bad. This is the active User agents exclusion list:

    bot
    is_archive
    slurp
    crawl
    spider
    Yandex
    
    Plugin Author Anton Vanyukov

    (@vanyukov)

    Yep, so you have defaults. Can you please try to clear this list and check if Hummingbird will cache AMP pages?

    Hrishikesh

    (@hrishikeshbharaligmailcom)

    I cleared the list but it still doesn’t cache AMP pages.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Ok. So it’s not related to HB settings. That’s good. Next step would be to try and enable Development mode in Cloudflare to check if it might be something from Cloudflare that is preventing HB from caching. Development mode can be turned on in Cloudflare, in the selected site Overview in Quick Actions panel on the right.

    Best regards,
    Anton

    Hrishikesh

    (@hrishikeshbharaligmailcom)

    I have enabled “Development mode” on Cloudflare and checked. HB Page Caching is still not working.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @hrishikeshbharaligmailcom,

    I’m not seeing any issues from what you have posted above. You can do a plugin conflict check to try and find a plugin that might be conflicting with Hummingbird. For that you would need to disable all plugins and enable them one-by-one to see which one prevents Hummingbird from caching.

    Best regards,
    Anton

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @hrishikeshbharaligmailcom,

    hope you’re doing well today! 🙂
    As we didn’t hear back from you for some time now, I’m marking this topic as resolved. Please feel free to post back any updates and we can re-open it and continue troubleshooting.

    Thank you,
    Dimitris

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Hummingbird Page Caching Not working on AMP Pages’ is closed to new replies.