Support » Plugin: Forminator Payment, Quiz and Contact Form Plugin » Hummingbird breaking Forminator Submission

  • Resolved mhwebdesign

    (@mhwebdesign)


    Hi there,

    I’ve got a problem with a site I’m working on. It’s a site I’ve taken over that was a bit of a mess with plugins, and suffered at the hands of a poor “web design” company. I’ve got it largely sorted out now though, albeit the framework, templates, and setup are still their doing.

    The contact form plugin I have chosen for them is Forminator. Looks great, and customer is really happy with how it works.

    Only one problem!

    We have been running with Hummingbird to try and speed the site up (I think part of it is host), and we’ve found that it appears to be breaking the form.

    By this, you fill in the form, press submit, and the button indicates it has been clicked, yet indents and comes back up again. No errors, No submission made, no nothing.

    I suspect it may be to do with minification of Java/CSS/HTML.

    When we clear the cache the form appears to start working find, but within 24-48 hours fails again.

    As we can’t afford that inconsistency we have had to uninstall Hummingbird and run without site caching.

    TESTING:
    1. Have tested in all browsers (Firefox/Chrome/IE v11) – same issue when it happens.
    2. We have 3 different forms on the site and all 3 are impacted when it happens.
    3. Initially we thought Autoptimize was the problem as we had both installed, but Autoptimize has since been uninstalled and the problem remained. Once Hummingbird cache is cleared the problem goes away.
    4. Using latest versions of PHP (7.x), WordPress, and plugins.

    Thanks for anyone that can assist us with this issue.

    • This topic was modified 1 month, 1 week ago by  mhwebdesign.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Interesting. I use both plugins without any conflicts/problems.

    Why do not you exclude the page containing your form from cashing and see if it changes anything.

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @mhwebdesign

    Just like @multidimentional mentioned, and thanks for that, can you try to enable the setting found in Edit form -> Behaviour -> Rendering -> Prevent page caching on form pages and see if this continues?
    https://monosnap.com/file/FbEcXSYMdvoJOUTjyOLafbwNT7HXI5

    Let us know how that goes!
    Thank you,
    Dimitris

    Hi Dimitris,

    Since my post I’ve flicked over to Cloudflare CDN, as well as another minification program whereby I can fine tune exactly what I want to be touched.

    As such I’d consider this one resolved, and if the above solution doesn’t work I’ll reinstall Hummingbird and implement your recommended changes.

    Thanks to both you and multidimensional!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.