Support » Plugin: Hustle - Email Marketing, Lead Generation, Optins, Popups » Huge white space after opt in

  • Resolved wherefoodtakesus

    (@wherefoodtakesus)


    I really love this plugin but I have 2 small issues.

    I have an embed and when I set it to disappear from my site once that user has opted-in then it leaves a huge white space. I don’t know if it matters but I use elementor. I currently have it set so that when people opt-in they can still see it because I’d rather them continue to see it instead of have a huge random white space.

    The other issue is with my slide-in. I noticed that if you opt-in with the embed then the slide-in will still show up even though that person already subscribed. Is there a way to fix this?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @wherefoodtakesus ,

    I have an embed and when I set it to disappear from my site once that user has opted-in then it leaves a huge white space. I don’t know if it matters but I use elementor. I currently have it set so that when people opt-in they can still see it because I’d rather them continue to see it instead of have a huge random white space.

    I have checked your site and there is no white space when submitting the embed (the success message disappears)

    The other issue is with my slide-in. I noticed that if you opt-in with the embed then the slide-in will still show up even though that person already subscribed. Is there a way to fix this?

    Have you selected No longer show this module across the site in Visibility after opt-in (Behaviour -> Additional Settings).

    kind regards,
    Kasia

    Thread Starter wherefoodtakesus

    (@wherefoodtakesus)

    Yes, I have it set to no longer show this module across the site but if someone opts in on the embed then the slide in doesn’t disappear.

    For me, the white space disappeared after submitting the embed but if you went to another post then there would be a white space.

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @wherefoodtakesus

    Yes, I have it set to no longer show this module across the site but if someone opts in on the embed then the slide in doesn’t disappear.

    As these are separate modules, then this would require some custom development.
    As far as I understand the embed and the slide-in are identical, so behavior should be inherited somehow. I’ve pinged our developers in case we could provide some custom code to do that trick, we’ll keep you posted about it.

    For me, the white space disappeared after submitting the embed but if you went to another post then there would be a white space.

    I can notice that. Are you using the No longer show this module across the site in Visibility after opt-in (Behaviour -> Additional Settings) like my colleague Kasia mentioned above?
    Just make sure you do that for the embed form, not only for the slide-in, as these are considered separate modules.

    Cheers,
    Dimitris

    Thread Starter wherefoodtakesus

    (@wherefoodtakesus)

    The embed form leaves a huge white space on my site after you opt-in. And I would really appreciate a way for my slide in to stop showing up.

    You can see the issue I’m having here:
    https://drive.google.com/open?id=1EQUnu9e7akLIXc3OMm6P7ZqGRLttYYlE

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @wherefoodtakesus

    The embed form leaves a huge white space on my site after you opt-in.

    As I mentioned in my previous reply, are you using the No longer show this module across the site in Visibility after opt-in (Behaviour -> Additional Settings) like my colleague Kasia mentioned above?
    Just make sure you do that for the embed form, not only for the slide-in, as these are considered separate modules.

    And I would really appreciate a way for my slide in to stop showing up.

    Also as mentioned above, that would require some custom coding as there’s no out-of-the-box settings that could “connect” an embed and a slide-in like this.

    Thank you,
    Dimitris

    Thread Starter wherefoodtakesus

    (@wherefoodtakesus)

    Yes, I am using the No longer show this module across the site after opt-in option. If you watch the screen recording you’ll see that after opting in and going to a new page, the area that had the embed form is now a huge white space.

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @wherefoodtakesus ,

    Thanks for the additional information. I can also replicate this on my site that embeds are leaving white space even they should not.
    I will report this to developers and they will check it.

    kind regards,
    Kasia

    Thread Starter wherefoodtakesus

    (@wherefoodtakesus)

    Thank you!

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @wherefoodtakesus

    As a workaround until the next plugin update, please replace the
    /wp-content/plugins/wordpress-popup/assets/js/front.min.js
    file with the one found in the following link:
    https://www.dropbox.com/s/h9hrnusenz1drhp/front.min.js.zip?dl=0

    Thank you,
    Dimitris

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Huge white space after opt in’ is closed to new replies.