Support » Plugin: Subscribe To Comments Reloaded » Huge number of 404s to pages “comment-subscriptions?srp=xxx”

  • In my logs of 404 Page Not Found (provided by Redirects) I get a huge number of 404 to URLs that look like this:

    “comment-subscriptions?srp=4780&srk=363317bd54a11cec5fcf1279de87609d&sra=s&srsrc=f”

    The “srp” number varies, as does the “srk”.

    “sra” seems always to be “s. “srsrc” is “f”, or is not present at all.

    Most seem to come from a bing-bot, some from other sources.

    I am guessing this has to do with the STCR plugin, but what is it? Where to these links come from? Can I make them not happen?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author WPKube

    (@wpkube)

    Hi @bkwineper

    Those are the “subscribe without commenting” links that you can see below the comment form. Every post has it’s own URL.

    But it shouldn’t be a 404 page, can you send over the URL to the website so I can give it a check?

    Thread Starter bkwineper

    (@bkwineper)

    Thanks for the super-quick reply. 🙂

    The web site is this one:
    https://www.bkwine.com/

    I have a week-long log of redirects that has about 3500 items. Around 1500 are of this kind.

    • This reply was modified 8 months, 2 weeks ago by bkwineper.
    Plugin Author WPKube

    (@wpkube)

    Hi @bkwineper

    You’re welcome, I was at the office and was doing a support round at the time so the answer was quick, unfortunately I wasn’t at the office during the weekend so this one is slower, sorry.

    I see you changed the management page URL slug to be manage-subscriptions-to-comments

    And it is functional, those URLs work https://www.bkwine.com/manage-subscriptions-to-comments/?srp=357710&srk=d487660111c19d415b93ef581ce29c06&sra=s&srsrc=f

    Did you maybe change the slug from comment-subscriptions to manage-subscriptions-to-comments recently?

    The only thing that comes to mind is that the slug was changed recently, but the caching plugin you use was still serving the old version of some posts which had the link to that page still with comment-subscriptions

    I looked at the page from the example you sent and currently the link in there uses the correct URL, so the cache was refreshed.

    Are the logs still showing 404s in the past day or so?

    Thread Starter bkwineper

    (@bkwineper)

    Yes, it is possible that I changed the slug. I can’t quite remember, but I did some changes some while back and I might have changed the slug. If “comment-subscriptions” is the default, then I have changed it not long ago, yes.

    Yes, I am still getting a lot of those 404s (and I have frequently cleared the cache over the last few days and weeks.

    Here’s an example from the log page of Redirection of today:
    https://www.bkwine.com/wp-content/uploads/2020/10/comment-subscription.jpg

    Could it be that search engines have logged all those (old) links and are still crawling them?

    If that’s the case, then I guess one could simply ignore them, don’t you think? Or what should one do with them? Redirect somewhere?

    At the same time, it seems pointless for search engines to crawl those links so maybe one should block search engines from /comment-subscriptions/ and from /manage-subscriptions-to-comments/?

    Plugin Author WPKube

    (@wpkube)

    Hi @bkwineper

    Those URLs are definitely visited by search engine bots.

    You could add a redirect from /comment-subscriptions to /manage-subscriptions-to-comments

    That way the bots get automatically redirected over to the new one.

    Thread Starter bkwineper

    (@bkwineper)

    Yes, but I wonder why this is happening? It is quite strange. It’s like 50%+ of all bot traffic. It does not seem healthy at all. It’s about one “hit” every 10 minutes.

    Is it that search engines have picked up on the subscription links from the previous configuration and keep looking for it?

    But I don’t see the point of directing a search bot to /manage-subscriptions-to-comments. What useful info will it find there? Why should that page rank in a search?

    Would it not be better:

    A) to block search engines from /comment-subscriptions and from /manage-subscriptions-to-comments?

    and

    B) redirect all those /comment-subscriptions to the home page?

    Plugin Author WPKube

    (@wpkube)

    Hi @bkwineper

    Bots go around and visit all links they find. Where exactly they find those URLs I’m not sure. Maybe rechecking because it’s a 404, maybe following a list that’s outdated, maybe somewhere on some website there’s links to those URLs…

    By default the page gets a “noindex,nofollow” so search engine bots disregard the content on it and don’t index it. You’re using a regular page for the management page so in the Yoast SEO options (from what I see you use Yoast SEO) for that specific page set it to not index.

    Then do a redirect from /comment-subscriptions to /manage-subscriptions-to-comments

    Bots will be automatically redirected to the correct page so they don’t get a 404 and then told not to index the page.

    Thread Starter bkwineper

    (@bkwineper)

    Thanks. Yes, I checked the setting and saw that it is indicated as “noindex,nofollow”. All good.

    I am guessing that the source of this “problem” must have been that at some stage in the life of the site that setting was NOT set to ‘noindex,nofollow’.

    I also changed the Yoast settings on the management page to:
    – Allow search engines to show this Page in search results? – NO
    – Should search engines follow links on this Page – NO
    – Meta robots advanced – all three NO
    (default was YES)

    I don’t imagine that this will have any effect since the bots should not arrive to the page anyway.

    I think I might redirect to the main page instead of to the management page. In time those links will disappear from the bots (I hope) and until then better to direct them to a useful page instead.

    Thanks for your support!

    Plugin Author WPKube

    (@wpkube)

    Hi @bkwineper

    You’re welcome. Let me know how it goes.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Huge number of 404s to pages “comment-subscriptions?srp=xxx”’ is closed to new replies.