Support » Fixing WordPress » Huge Mistake-Domain

  • I wanted to change my domain name so I went to settings and general and copied and pasted the following into the name space and the url space.


    Then I hit save changes. Now when I try to access my website it says “Error establishing a data base connection” and I can’t get to anything. HElp please??

Viewing 10 replies - 1 through 10 (of 10 total)
  • I should make clear that I did not actually use “” in those blanks. I typed in the name of the domain that I wanted it changed to. 🙂

    Yes – but was your server configured to use that domain name? And were your wordpress files located in such a way that that domain would be correct?

    But learning experience aside, let’s get your WordPress site back to a usable state. Read through this:

    I generally like to use the database approach myself as it’s quick, fairly painless, and you don’t have to go about editing files.

    Well, the quick fix is to go back in and remove those lines.

    There’s more to setting it up to connect to a domain than just telling WordPress to use that domain. Your webserver itself must know about that domain and know that it needs to connect that domain to where WordPress is actually installed.

    The problem is that I understand so little of what I’m doing. I’m dangerous that way. I read the database approach but I don’t know what it means to access “php My Admin” and I don’t know how my server is configured and I don’t know where my files are located. I jumped in with both feet but now I’m drowning! Sorry to be such an idiot my first time out. Can someone walk me through step by step what I need to do? Should I just cancel and start over?


    Forget phpMyAdmin for now.

    First step: Remove the changes you made. Those lines you say that you added are breaking your site. So remove them and your site will come back.

    Changing the URL in WordPress is actually the last step in the process. The first step is actually getting that URL and setting up your webserver or hosting account to point the URL at your site.

    Additional: Okay, I saw that you had defines there, so I thought you edited files. But, you say that you put them into Settings->General? In which case, yeah, that’s a problem.

    What kind of access to your site do you still have? You will need either access to the files on the site, or access to the database (via phpMyAdmin). Some kind of access is required.

    Well if you haven’t created a lot of content or done much yet, I would start over – at least from that point you’ll have a “fresh” start. But if you feel like you need to keep what you have, follow these steps.

    1) Get access to the database. You can use PHPMyAdmin to do this. Contact your host if you have questions or need access to PHPMyAdmin.

    2) Using PHPMyAdmin locate your WordPress site’s database. Inside that table there will be a “wp_options” table. Select it.

    3) Use “Browse” to see the data inside the wp_options table. Inside this table are two rows we’ll be editing – “siteurl” and “home”. Click in the Option Value column to change the values for these two rows back to the correct domain/url where your site sits.

    4) Now point your browser back at the URL where your site sits and you should see your WordPress site again.

    Otto – Thanks for the help but I’m still having difficulty. Do I need to go to or I didn’t realize there were two different sites. When I tried to access it said that my account was created when I signed up with Akismet and that I would need to activate my account. When I went to activate my account it said that my account is activated. In the meantime, I don’t know where to go to get back to the page where I remove the changes that I made.

    Otto, go gently on me. I’m in my 50s. 🙂

    In terms of accessing my site, the original domain name was but when I try to access it I get the message “Error Establishing a Database Connection”. In the meantime how do I access PHPMyAdmin and how do I know who my host is?

    If I start over, what would be the best way to do that and would I have to pay to do that?

    Your “host” is whomever you’re actually paying to have your site.

    According to, your site appears to be hosted by InMotion Hosting. Does that sound familiar?

    You’ll need to log into your hosting account in order to access the database and/or files on the site.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Huge Mistake-Domain’ is closed to new replies.