Support » Plugin: NextGEN Download Gallery » HUGE Memory consuption in preview

  • I have 1.4.2 (and about to have 1.4.3) and I have a HUGE memory consumption when I look at galleries (lightbox or whatever is in use).

    I looks like AJAX is storing every viewed picture in cache. With few pictures it is not a problem, but when it is bigger gallery (like 200 pics), it is really a problem, when Chrome/FF takes 3 GB of RAM on system with 4 GB 😉

    Standalone lightbox or shadowbox doesn’t do this, so it “must” be on your side 🙂 🙂

    Just try one of my bigger gallery and watch what is happening with free RAM.

    Test gallery (link).

    Thank you! 🙂

    https://wordpress.org/plugins/nextgen-download-gallery/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author webaware

    (@webaware)

    G’day Rudolf,

    I didn’t see the memory problem when viewing the page, in either Firefox or Chrome (on Linux), but I did see a problem when attempting to download the zip file. Your system prevents increasing the time limit for script execution, so I’ll need to make a change.

    Please download and try this version, and let me know how you go.

    https://dl.dropboxusercontent.com/u/26305751/nextgen-download-gallery-1.4.4-alpha1.zip

    cheers,
    Ross

    Hi, I’ll try it, but the RAM problem is here, look at usage in this graph, I have viewed only about 100 pictures and look at the consumption 🙂

    http://www.dark-net.cz/files/nokialumia.png

    I’ve downloaded that alpha version, I just rewrite my old nggalery and it should work, I hope 🙂 I’ll notice you about download problem (I haven’t notice it 😀 )

    I have a very fast internet, so maybe I didn’t notice it, but I tried (now with alpha version installed) to download that “nokia lumia” album and it worked like a charm.

    How was the bug look like? I don’t know where to start even to look for, but it worked before and it is working now, I think 🙂

    Plugin Author webaware

    (@webaware)

    G’day Rudolf,

    That’s not this plugin, that’s just your browser — or possibly a memory leak in one of NextGEN Gallery’s scripts. Perhaps ask NextGEN Gallery (Photocrati) for some advice there.

    The bug I fixed in 1.4.4-alpha1 was that your website started dumping the .zip file to the browser with some warnings, so the browser couldn’t detect it as a .zip file. The specific warning that triggered it was:

    Warning: set_time_limit() has been disabled for security reasons

    which is what 1.4.4-alpha1 fixes. I’ll make a release with that fix soon.

    BTW, are you interested in contributing a Czech translation of the plugin?

    cheers,
    Ross

    Nice work, thanks 🙂

    Yep, I understand 🙂

    About that translation, I can make it, if you want 🙂 I hace som expierence in this, but I’ve never published anything, just for my own usage 🙂

    R. K.

    Plugin Author webaware

    (@webaware)

    I’m sure other Czech users of the plugin would appreciate it if someone translated those 10 strings. All you need to do is register as a user, then login and edit. Very easy with GlotPress.

    cheers,
    Ross

    Of course, I’ll do that, just a minute 😉 😉

    Okay, check it out, I hope it isn’t wrong 🙂 🙂

    Plugin Author webaware

    (@webaware)

    G’day Rudolf,

    Many thanks! I just released v1.4.4 with the set_time_limit() error fix, and your shiny new Czech translation. Thanks for taking the time!

    cheers,
    Ross

    I’ll chceck it, thanks 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘HUGE Memory consuption in preview’ is closed to new replies.