Support » Plugin: Featured Images in RSS for Mailchimp & More » Huge log file keeps growing

  • Resolved amazemedia

    (@amazemedia)


    Log file keeps growing with these lines:

    [05-Nov-2020 16:58:15 UTC] PHP Notice: Trying to get property ‘plugin_path’ of non-object in /nas/content/live/mywebsite/wp-content/plugins/featured-images-for-rss-feeds/includes/freemius/start.php on line 189
    [05-Nov-2020 16:58:15 UTC] PHP Notice: Undefined index: post-to-google-my-business/freemius in /nas/content/live/mywebsite/wp-content/plugins/featured-images-for-rss-feeds/includes/freemius/start.php on line 277

    • This topic was modified 6 months, 1 week ago by amazemedia.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author 5 Star Plugins

    (@5starplugins)

    Hi @amazemedia I will look into these PHP notices and see about resolving them. It looks to be inside the Freemius 3rd party SDK we’re using, so I will look into updating the SDK soon to see if that helps.

    In addition, it is also best practice for production sites with a lot of traffic to set WP_DEBUG to False, and/or turn off PHP Notice logging, there are many reasons a PHP notice could be generated, and notices do very often create very large log files.

    Logging only Errors is best, logging only Warnings and Errors second best.

    Thank you for taking the time to submit this topic, and we’ll post an update here once the SDK is updated, along with a version bump on the plugin itself.

    Thread Starter amazemedia

    (@amazemedia)

    Thank you much appreciated

    Plugin Author 5 Star Plugins

    (@5starplugins)

    Hi @amazemedia, we’ve released a new version 1.5.7 of the plugin that includes the latest version of the Freemius SDK. Perhaps this helps with the PHP Notices you were seeing in the logs.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.