Support » Plugin: Subscribe To Comments Reloaded » Huge influx of spam

  • Morning. Looks like there’s an issue with the Subscribe to Comments Reloaded plugin.

    In the last week or two I kept getting ‘thanks for your message’ auto-emails to an email address I don’t actively use it. I checked my gmail Sent box and nothing – my thought was that someone must be spoofing that address.

    Then last night, one came in with the original email still attached and it was a STCR ‘thanks for subscribing’ email!

    So I looked in my STCR subscriptions are there were hundreds per day – mainly vaping email addresses, but also loads of business ones, obviously used by spammers.

    So, I went in to STCR and noticed it had an update so I ran that. Looked at the dev notes and there was something about adding better CAPTCHA food “subscribe without commenting”.

    I ran the update, then looked for a toggle to turn off “subscribe without commenting” but there isn’t one! I was able to remove the link by deleting it from the text that appears under the comment box. I flushed the whole cache and went to bed.

    This morning there were dozens of new spam subscriptions in STCR – more, in fact, than there were even spam comments, so how are they getting through?

    For the moment, I’ve deactivated STCR.

    • This topic was modified 5 months, 1 week ago by emilyel.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author WPKube

    (@wpkube)

    Hi @emilyel

    Sorry to hear that.

    In the latest update Google reCAPTCHA functionality was added to battle the spam submissions through the “subscribe without commenting” and “request management link” forms.

    You can enable that in WP admin > StCR > Options. The options for it are at the bottom, it’s the on/off toggle and “reCAPTCHA site key” and “reCAPTCHA secret key”.

    In the next update (this week) we’re also adding an option to completely disable those 2 forms.

    In the meantime try enabling the reCAPTCHA functionality and let me know if you’re still getting spam submissions.

    lebucheron

    (@lebucheron)

    Hi

    Is there an update on disabling subscribing without commenting ?

    Thanks

    Thread Starter emilyel

    (@emilyel)

    I’d like to know this too. For the moment I’ve had to remove the plugin entirely.

    Plugin Author WPKube

    (@wpkube)

    Hi @emilyel @lebucheron

    In the last update on January 26 we added the options to disable those pages.

    Option to disable the “subscribe without commenting” and “request management link” pages. ( WP Admin > StCR > Management Page )

    lebucheron

    (@lebucheron)

    Indeed, I was looking in the “options” tab, and it was in another one.

    Thanks

    Plugin Author WPKube

    (@wpkube)

    You’re welcome @lebucheron

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.