Support » Installing WordPress » Huge bug in 2.9

  • When doing a fresh install of 2.9, for some reason the setting for the uploads folder is not set correctly (actually it’s not set at all). Dashboard->Settings->Miscellaneous->Store uploads in this folder
    For some reason the default is not there, it’s blank! Anybody know if this has been fixed in 2.9.1???

Viewing 6 replies - 1 through 6 (of 6 total)
  • If that field is blank the uploads will default to wp-content/uploads. Not sure anything has changed with that in 2.9 or 2.9.1 so pretty sure that is not a bug.

    When calling upload_path it returns empty. I had to manually set wp-content/uploads. I’m not the only person having this problem either.

    Just installed 2.9.1 and didn’t have a problem adding an image to a post. It did put the image in wp-contents/uploads.

    Noticed that includes/functions.php has this:

    $upload_path = get_option( 'upload_path' );
    $upload_path = trim($upload_path);
    if ( empty($upload_path) ) {
    $dir = WP_CONTENT_DIR . '/uploads';

    Weird. Check out all the problems ppl have been having with 2.9 and this plugin. I haven’t tried 2.9.1 yet.

    Mingle WordPress Plugin

    The problem only happens with WP 2.9 and we’ve narrowed the problem down to get_option(‘upload_path’); returns nothing. After manually setting it to wp-content/uploads in the WP Misc. settings it works just fine.

    The install seems to create that option with a blank value so don’t know if that’s intentional or not.

    At this point it’s an easy fix, I just can’t figure out why when it’s blank it’s not defaulting back to wp-content/uploads.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Huge bug in 2.9’ is closed to new replies.