Support » Plugin: Uncanny Toolkit for LearnDash » Huge bug

  • After more than 10 hours searching….we found why it was impossible to saved modifications on our website (last version of wordpress and divi)… it’s your plugin 🙁

    It was difficult to find it because we tested each plugin clearing only cache files with no success.

    We had to start clearing the browser cache files and cookies too, and enabling one by one all the plugins and testing editing pages… and finally the result is that once your plugin is enabled we cant edit and save pages, posts….

    Is there a way to solve this problem?
    We really spent hours and hours with 2 specialists, divi support…

    • This topic was modified 5 months, 3 weeks ago by fulviods.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Uncanny Owl

    (@uncannyowl)

    Hi @fulviods, sorry to hear about the issue. We haven’t had similar reports but let’s see if we can trace it.

    First, we tried this ourselves with WordPress 5.5.2, LD 3.2.3.6, Toolkit 3.3.4 (with all modules enabled) and Divi 4.6.6. We didn’t see any issues. Were you also testing with the latest versions?

    You mentioned you traced it to the Toolkit, but did you test with ONLY LearnDash, the Toolkit and Divi active? We want to rule out the issue happening because something else created a conflict with the Toolkit. Can you also confirm that this was with the latest Divi parent theme selected, not a child theme with overrides?

    If there is a failure on save, you may see an error in the console; right-click the page, choose Inspect, and let us know if you do see errors in the console tab.

    When you were testing, did you see the issue with the Toolkit enabled but all modules disabled? In other words, were you able to trace the issue to a specific module in the Toolkit?

    Is the issue happening for all post types or are you having issues with a single post type?

    Finally, we wanted to confirm what browser and operating system you’re using.

    Thanks!

    Thread Starter fulviods

    (@fulviods)

    i have the last versions of everything

    I spent again time testing what you asked me.
    I disabled all the plugins except Toolkit and LMS. We have an emtpy child theme so it dosent change anything it just call the main theme.

    And here too, when I enable the Toolkit I have the problem
    I forgot to tell you its a mulitsite website

    I have last version of chrome and same problem on firefox, I’m on windows 10

    Plugin Author Uncanny Owl

    (@uncannyowl)

    Thanks for testing. Can you confirm your results with disabling individual modules? We do want to know if it’s a specific module causing you problems. And is this all post types or specific ones only? We do have test environments matching what you describe, including the versions, but we cannot reproduce this.

    If you are a Pro user, can you proceed with logging a ticket in your account on our website? Access would be helpful for us to have a look at the environment ourselves.

    If you’re not a Pro user, confirming the questions above would really help. Does it happen even if no modules are active in the Toolkit, so just the plugin is enabled?

    Thread Starter fulviods

    (@fulviods)

    We didnt try disabling individual modules. We are not a pro user.

    so we spent many hours and we have done other tests disabling modules and enabling one by one and we found the problem occurs wehen the module “Front End Login” is enabled.

    So now we know exactly where the problem is.

    Actually we are going to disable it when we have to do modifications on the website but hope you could find a solution.

    Plugin Author Uncanny Owl

    (@uncannyowl)

    Hi @fulviods, we have tried reproducing it but we’ve been unable to do so. We use both Front End Login and Divi widely. Just to reconfirm, you are saying that on WordPress 5.5.x, with the latest Divi version, an empty child theme active and ONLY the Toolkit enabled (no other plugins) and only the Front End Login module turned on, you still can’t save posts in Divi? And nothing in the console of the browser gives you more clues? Does it change if the Toolkit is network activated vs. only be activated on the single site?

    If you have a Staging site and can send us access on our website (after confirming the above), maybe we could take a quick look. This is really strange.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.