Support » Plugin: AMP for WP - Accelerated Mobile Pages » Huge AMP Validation Issue, URLS removed from Index

  • anguille444

    (@anguille444)


    Hello,

    I am contacting you regarding an issue I have with my website since the last update a few days ago. It appears that the Analytics Code is messing with AMP validation test and many of my web pages are therefore not AMP friendly.
    It wasn’t like that ever since I used the plugin, please could you check this issue ? I have removed the analytics code so the pages are AMP friendly again but I would like to add it back,

    Best Regards,

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • frenchomatic

    (@frenchomatic)

    You could try to add your analytics code manually into the head using functions.php . I use this technique to insert hreflang tags and local business schema.org json markup.

    function amp_my_analytics_speciall() {
    ?>
    <script ....
    your analytics code
    <?php
    }
    
    add_action( 'amp_post_template_head', 'amp_my_analytics_special');
    Plugin Author Mohammed Kaludi

    (@mohammed_kaludi)

    Hi @anguille444

    That’s strange, we haven’t been reported any analytics issues on validation.

    As of now, your amp seems valid, can you please enable the analytics? so that I can check?

    or atleast if you can post a screenshot of the error that you got?

    Plugin Author Mohammed Kaludi

    (@mohammed_kaludi)

    Hi @thetester113

    I am sorry to hear that, May I know your website URL?

    Your issue could be different from the original thread creator.

    But Please send me the URL, I will help you fix it.

    Thread Starter anguille444

    (@anguille444)

    Without analytics activated in your plugin it’s ok.

    Otherwise there is a screenshot, same error on all pages :

    https://imgur.com/WJc7LID

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Hi @anguille444

    That’s very strange, We haven’t seen this issue before.

    Can you please just contact us on team@magazine3.com and mention that Ahmed will be having a deeper look into this.

    We will make sure that this gets fixed for you

    Thread Starter anguille444

    (@anguille444)

    After your intervention the problem seems to be fixed.

    Thank you to your team, and here is a screenshot of the solution for my case :

    https://imgur.com/a/TdO8Y

    This area was previously empty.

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Hi @anguille444

    I’m glad to hear that it was fixed.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Huge AMP Validation Issue, URLS removed from Index’ is closed to new replies.