Support » Theme: Hueman » Hueman 3.7.12 destroy columns in many web browsers

  • Resolved unjayec

    (@unjayec)


    I am using Hueman 3.7.11 and I am satisfied, modyfying as I need. Recently I developed child theme to it.

    However, version 3.7.12 works good with Chrome, but didn’t work properly on any other browser like: Avast, FireFox or Edge. Browsers show multicolumn site sequentially.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Thread Starter unjayec

    (@unjayec)

    Let’s compare what differs Hueman.3.7.11:

    $full_width_widget_html = ob_get_contents();
          ?>
          <?php if ( ! empty($full_width_widget_html) ) : ob_end_clean(); ?>
            <section class="container" id="footer-full-width-widget">
              <div class="container-inner">
                      </div><!--/#credit-->
                  <?php
                    $credits_html = ob_get_contents();
                    if ($credits_html) ob_end_clean();
                    echo apply_filters( 'hu_credits_html', $credits_html );

    with Hueman.3.7.12:

    $full_width_widget_html = ob_get_clean();
          ?>
          <?php if ( ! empty($full_width_widget_html) ) : ?>
            <section class="container" id="footer-full-width-widget">
              <div class="container-inner">
                      </div><!--/#credit-->
                  <?php
                    $credits_html = ob_get_clean();
    
                    echo apply_filters( 'hu_credits_html', $credits_html );

    In some other places function call “ob_get_contents()” is substituted by “ob_get_clean()” and its incompatibility is probably a problem for plenty of web browsers.

    Same thread as this one?

    I don’t quite understand what you mean and what the problem is. You write “Browsers show multicolumn site sequentially.” Do you mean that the blog posts are displayed in just one column instead of two?

    I checked your website with both Firefox and Safari on my iMac (5K 27″). Your site displayed blog posts in two columns in both browsers.

    PS: I’m not an expert, so unfortunately I can’t help any further. I just wanted to report that your site displays posts in multicolumn (two) in both Firefox and Safari on Mac.

    Thread Starter unjayec

    (@unjayec)

    Yes, my site works fine on every browser, because I’ve been forced installation of theme Hueman 3.7.11 blocking update to fatal Hueman 3.7.12. I don’t want to present my users invalid web page of my blog. Yes this faulty theme 3.7.12 shows my blog almost like on mobile devices, but it is evidently invalid view.

    Thread Starter unjayec

    (@unjayec)

    Here are screenshots:
    HUEMAN.3.7.12 in Avast secure browser and probably some otherwrong screen HUEMAN.3.7.12
    HUEMAN.3.7.11 correct screen HUEMAN.3.7.11

    Theme Author Nicolas

    (@nikeo)

    Helle @unjayec,
    Thank you for opening this topic. I’m not able to reproduce the described issue on my test sites.
    It might be an issue created by the child theme. Can you confirm that the problem occurs even when using the main parent theme, and not the child theme one ?

    Thread Starter unjayec

    (@unjayec)

    Thank you for the responce Nicolas.
    CHILD theme I have create few days ago, but problem was from the beginning of “12”.
    May I offer you creating user for you?
    Which priviledges I must give you?

    Theme Author Nicolas

    (@nikeo)

    So the problem was here with the latest version, even without a child theme ? Can you confirm this point ?

    Login to your website won’t be possible. As per the forum rules, it is not allowed to request an admin access on the WordPress forums.

    If the child theme is not the problem, please describe, with as much details as possible, how I can reproduce the problem easily on a test site.
    Thank you

    Thread Starter unjayec

    (@unjayec)

    As you can see on PC I have 4 columns layout.
    4 column layout
    Two in the middle are for posts headers or for one open complete post.
    Left is for: tags cloud, last comments list, archive – month selection, post in calendar(selected month) and one picture link.
    Right is for: Categories list, Posts in months, and popular posts.
    Footer contains my logo, main menu and social menu.
    Header contains menu, customized header picture and textual social menu.

    Theme Author Nicolas

    (@nikeo)

    OK. I’m not able to reproduce the described issue for the moment when using Hueman v3.7.12.
    I see that you sill use the child theme on your website, it can be the cause of the problem.
    Try to activate the parent theme and update the theme to the latest version.
    The recommended process is to make your test on a staging site.

    Thread Starter unjayec

    (@unjayec)

    For sure, child theme is not a problem, because destroyed screen was observed many days before I’ve been used child theme. And why child theme must be a problem. Did you create wordpress environment like in my site? i.e.:

    As you can see on PC I have 4 columns layout.
    4 column layout
    Two in the middle are for posts headers or for one open complete post.
    Left is for: tags cloud, last comments list, archive – month selection, post in calendar(selected month), and one picture link.
    Right is for: Categories list, Posts in months, and popular posts.
    Footer contains my logo, main menu and social menu.
    Header contains menu, customized header picture and textual social menu.
    Thread Starter unjayec

    (@unjayec)

    In the folder: themes/hueman-child I have 3 files:
    style.css:

    /*
     Theme Name:   Hueman Child
     Theme URI:    https://doktorB.it/hueman-child/
     Description:  Hueman Child Theme
     Author:       Andy Bit
     Author URI:   http://doktorB.it
     Template:     hueman
     Version:      3.7.11
     License:      GNU General Public License v2 or later
     License URI:  http://www.gnu.org/licenses/gpl-2.0.html
     Tags:         light, dark, two-columns, right-sidebar, responsive-layout, accessibility-ready
     Text Domain:  huemanchild
    */

    functions.php:

    <?php
    add_action( 'wp_enqueue_scripts', 'my_theme_enqueue_styles' );
    function my_theme_enqueue_styles() {
        wp_enqueue_style( 'child-style', get_stylesheet_uri(),
            array( 'parenthandle' ), 
            wp_get_theme()->get('Version') // this only works if you have Version in the style header
        );
    }

    comments.php:

    <?php if ( post_password_required() ) { return; } ?>
    
    <section id="comments" class="themeform">
    
    	<?php if ( have_comments() ) : global $wp_query; ?>
    
    		<h3 class="heading"><?php comments_number( __( 'No Responses', 'hueman' ), __( '1 Response', 'hueman' ), __( '% Responses', 'hueman' ) ); ?></h3>
    
    		<ul class="comment-tabs group">
    			<li class="active"><a href="#commentlist-container"><i class="far fa-comments"></i><?php _e( 'Comments', 'hueman' ); ?><span><?php echo count($wp_query->comments_by_type['comment']); ?></span></a></li>
    			<li><a href="#pinglist-container"><i class="fas fa-share"></i><?php _e( 'Pingbacks', 'hueman' ); ?><span><?php echo count($wp_query->comments_by_type['pings']); ?></span></a></li>
    		</ul>
    
    		<?php if ( ! empty( $comments_by_type['comment'] ) ) { ?>
    		<div id="commentlist-container" class="comment-tab">
    
    			<ol class="commentlist">
    				<?php wp_list_comments( sprintf( "avatar_size=%s&type=comment", apply_filters('hu_avatar_size', 48 ) ) ); ?>
    			</ol><!--/.commentlist-->
    
    			<?php if ( get_comment_pages_count() > 1 && get_option('page_comments') ) : ?>
    			<nav class="comments-nav group">
    				<div class="nav-previous"><?php previous_comments_link(); ?></div>
    				<div class="nav-next"><?php next_comments_link(); ?></div>
    			</nav><!--/.comments-nav-->
    			<?php endif; ?>
    
    		</div>
    		<?php } ?>
    
    		<?php if ( ! empty( $comments_by_type['pings'] ) ) { ?>
    		<div id="pinglist-container" class="comment-tab">
    
    			<ol class="pinglist">
    				<?php // not calling wp_list_comments twice, as it breaks pagination
    				$pings = $comments_by_type['pings'];
    				foreach ($pings as $comment) { ?>
    					<li class="ping">
    						<div class="ping-link"><?php comment_author_link($comment); ?></div>
    						<div class="ping-meta"><?php comment_date( get_option( 'date_format' ), $comment ); ?></div>
    						<div class="ping-content"><?php comment_text($comment); ?></div>
    					</li>
    				<?php } ?>
    			</ol><!--/.pinglist-->
    
    		</div>
    		<?php } ?>
    
    	<?php else: // if there are no comments yet ?>
    
    		<?php if (comments_open()) : ?>
    			<!-- comments open, no comments -->
    		<?php else : ?>
    			<!-- comments closed, no comments -->
    		<?php endif; ?>
    		<?php 
    			 $u_time = get_the_time('U'); 
    			 if (time()-$u_time>2*24*3600) : ?>
    			<section
    			id="comments" class="themeform"><h3 class="heading">1 komentarz</h3><ul
    			class="comment-tabs group"><li
    			class="active"><a
    			href="#commentlist-container"><i
    			class="far fa-comments"></i>Komentarz<span>1</span></a></li><li><a
    			href="#pinglist-container"><i
    			class="fas fa-share"></i>Pingbacki<span>0</span></a></li></ul><div
    			id="commentlist-container" class="comment-tab"><ol
    			class="commentlist"><li
    			class="comment even thread-even depth-1 parent" id="comment-35"><div
    			id="div-comment-35" class="comment-body"><div
    			class="comment-author vcard">
    			<img
    			alt='' src='https://secure.gravatar.com/avatar/20a9116a97015bf1b20ea9d70640a382?s=64&d=wavatar&r=pg' srcset='https://secure.gravatar.com/avatar/20a9116a97015bf1b20ea9d70640a382?s=128&d=wavatar&r=pg 2x' class='avatar avatar-64 photo' height='64' width='64' loading='lazy'/> <p><a href='https://doktorB.it/' rel='external ' class='url'>Andrzej P.Urbański</cite> <span
    			class="says">pisze:</span></div><div
    			class="comment-meta commentmetadata">
    			<a
    			href="#comment-35"><?php echo date ('Y-m-d', time()-86400); ?>, o <?php echo rand(10, 22).":".rand(11,59); ?></a> &nbsp;&nbsp;</div><p><img src="https://doktorB.it/koment.jpg" width="100" align="right"> Ten wpis o tytule <i>"<?php echo get_the_title();  ?>"</i> z kategorii "<?php the_category(' <span>/</span> ');  ?>" dotyczący: <?php echo get_the_tag_list('',', ','');  ?>, czeka na Twój komentarz. Na pewno masz na ten temat coś ciekawego do powiedzenia. Co sądzisz o tym, co napisałem?</p>
    			</div>
    			</li></ol></div>
    		<?php endif; ?>
    	<?php endif; ?>
    
    	<?php if ( comments_open() ) { comment_form(); } ?>
    
    </section><!--/#comments-->

    The last implements “ghost comments” from me trying to inspire readers to write real comment, when one write it my “ghost” disappear.

    Thread Starter unjayec

    (@unjayec)

    Is there a file with my configuration of hueman theme which I can send you that you can copy my configuration?

    Thread Starter unjayec

    (@unjayec)

    As you requested, I’ve just disabled Hueman-child and update to Hueman.3.7.12. Screen of the Avast browser is invalid as I show you. Screens of FireFox and Edge are OK, but I don’t know how to refresh these browsers cache.
    Please, help me.

    Thread Starter unjayec

    (@unjayec)

    Dear Nicolas,

    I’ve just have been completely purge cache in these browsers: FireFox, Edge and Avast secure browser.
    It didn’t destroy like previously page view screen.
    In case of Avast it has been made page working properly!
    Success! Maybe it was a problem of cache refresh beetween 11 and 12 versions of Hueman.
    Thank you for your help.
    Sorry for disturbing you.
    I will go back to hueman-child.
    Good luck!
    Greetings.

    Theme Author Nicolas

    (@nikeo)

    That’s good news.
    Best wishes for your project on the web.

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.