HTTPS/SSL Google Font Issue (4 posts)

  1. brandonmcconnell
    Posted 3 years ago #

    Ever since I bought my SSL certificate yesterday, my theme's main font no longer works. It gets automatically switched to Times New Roman. I now force a SSL redirect to ensure security. My wordpress is located at pinemtncc.com.

    From the little bit of research I've been able to find on this issue, the main concern has been with this one line of code, located in style.css:

    @import url(https://fonts.googleapis.com/css?family=Rokkitt);

    The link from the original line of code points to
    https://fonts.googleapis.com/css?family=Rokkitt. This URL comes up as shown below:

    @font-face {
      font-family: 'Rokkitt';
      font-style: normal;
      font-weight: 400;
      src: local('Rokkitt'), url(https://themes.googleusercontent.com/static/fonts/rokkitt/v5/4Z-2qkHrI1biwaOxvW6ZTA.woff) format('woff');

    I'm really desperate for an answer if anyone can help. Please help me find out what's ruining my site.

    PS: I am using Google Chrome

  2. s_ha_dum
    Posted 3 years ago #

    Ok. First, what kind of security are you trying to achieve with the encrypted connection (https)? I don't really see anything on the front end that would justify the overhead.

    Second, two of your stylesheets are returning 404 errors. In case you are not aware of that, these are "https://pinemtncc.com/wp-content/themes/blackbirdtheme/css/color/Default.css?ver=3.4.2" and "https://pinemtncc.com/style.css".

    Finally, "Rokkittt" seems to be loading OK for me in FireFox and Chrome. I see very distinct font changes when I toggle the CSS rules.

    Do you see this problem on other computers? It could be a setting or plugin in your browser.

  3. brandonmcconnell
    Posted 3 years ago #

    Turns out I just needed to clear my cache and cookies after installing the new SSL certificate. But about the 404 errors, how will that affect my site? And how should I go about fixing them?

  4. s_ha_dum
    Posted 3 years ago #

    The 404 errors will slow down the site load time and probably break the formatting somewhere, as I assume the stylesheets are trying to load for a reason. This one, "https://pinemtncc.com/style.css", might just be a mistake. It is not common for stylesheets to load from root on a WordPress site. There is a line in (probably) your theme's header.php that is causing the issue:

    <link rel="stylesheet" type="text/css" media="all" href="https://pinemtncc.com/wp-content/themes/blackbirdtheme/style.css" />
    <link rel="stylesheet" href="style.css" />

    That second line should probably not be there. I don't know why it is.

    This one, "https://pinemtncc.com/wp-content/themes/blackbirdtheme/css/color/Default.css?ver=3.4.2", I suspect is a filesystem permission problem. Do you know how to check filesystem permissions?

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.