Support » Plugin: WordPress HTTPS (SSL) » HTTPS WordPress Plugin strips font and hides widget

  • Resolved licoricefrog


    Hi there,

    I installed HTTPS WordPress Plugin in conjunction with a purchased SSL certificate to secure an accommodation booking form – here’s the URL:

    Upon activating the plugin and securing the ‘book’ page I have noticed that the plugin has striped the font ‘Rockwell’ on this page (‘Font Uploader’ is the plugin being used to add this font.) This font features in the main menu and heading elements.

    I’m also using the ‘Widget Context’ Plugin to enable an HTML widget to be seen on this page and since installing HTTP WordPress it has disappeared.

    Any assistance would be appreciated to restore the font and widget on this page.


Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mike Ems


    Whatever you’re using for the fonts is not SSL aware. I don’t know if it’s a plugin or your theme, but it’s attempting to load the font from an HTTP URL, so it’s not loading properly. Unfortunately, the plugin can not resolve this.

    As for the disappearing widget, I really can’t help you there. The plugin doesn’t have any conflicts with other plugins, so you’ll have to provide more detail.


    We are currently experiencing the same issue on our site. We secured our entire site for online sales, we were getting unsecure content errors, so we installed WordPress HTTPS (SSL) plugin which resolved the unsecure content issues, but now many fonts, styles of the theme we are using are not showing correctly.

    Did you ever find a resolution to your issue?

    Thanks and regards

    Hi Hamish,

    I’ve been able to fix the widget error (it displays now), but I’m still stuck on the font issue.

    As mentioned in my original post, I’m using the ‘Font Uploader’ WP plugin for the ‘Rockwell’ font. Not sure where to go from here :S

    I tried manually installing the font via CSS but still end up with the same issue. I’ll continue to troubleshoot and will come back to you if I reach a resolution.

    Anyone out there that wishes to take a stab please be my guest! 🙂

    Plugin Author Mike Ems


    If you’d like, you can try the development version. I’ve added some checks for fonts. Let me know if it works for you.


    The development version has worked – thank you very much!

    Hamish, try downloading the dev version, worked for me – good luck 🙂

    Hi, sadly it didnt work for me.
    The fonts are located in a subfolder of the theme like /wp-content/uploads/dottoro/web_fonts/ARIALN/ARIALN.woff

    And I tried to add a secure filter for it like (.*).ttf also didnt work and like ^(.*).ttf which didnt work either.

    Any help would be appreciated.

    Hi, this plugin helped me out:
    at the bottom. But it only can be kind of a short hand fix, cause I would not like to use another plugin to fix an existing plugin…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘HTTPS WordPress Plugin strips font and hides widget’ is closed to new replies.