WordPress.org

Forums

WP Super Cache
HTTPS will not forward to HTTP on non-secure pages, when Super Cache is active (3 posts)

  1. wboykin
    Member
    Posted 2 years ago #

    WordPress HTTPS (SSL) Version 3.3.6
    Conflict with WP Super Cache Version 1.3.2

    The HTTPS plugin is set to redirect users to HTTP if a page is not secure, but this does not work after Super Cache starts caching pages. Is this a known problem? It appears that the caching is bypassing the secure rewrite rules.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. cdanni
    Member
    Posted 2 years ago #

    Following up on wboykin's post (we work together):

    The site in question had options set in HTTPS for domain mapping for sharethis.com and gravatar.com.

    We have another site that uses both plugins, same versions, same WP core (3.5.1) and it redirects to HTTP on non-secured pages just fine. The only difference is that it doesn't have anything listed for domain mapping.

    At this point we aren't sure which plugin is causing the issue, so I'm going to follow up in the other plugin's support forum as well.

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    I've never used "WordPress HTTPS" so I can't comment on that. I would say you should debug that plugin, adding error_log statements to find out how it works. I presume it's a relatively small plugin so shouldn't take long, especially if the problem is consistent.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags