Support » Fixing WordPress » https weirdness

  • Resolved kaliayev


    Hi there,

    I am running WordPress 3.3.2 on Debian stable (6.0.5 so far), served by apache2.

    I want WordPress to act as a website (not a blog, so no post, or anything else)… And I also want the login page (hence mainly wp-admin) to be redirected to https for security reasons.

    I read, and added:
    define('FORCE_SSL_ADMIN', true);
    to /etc/wordpress/config-my.fqdn.tld.php to that end.

    I also know that I have to enable https for my.fqdn.tld, so I have this wordpress-related config in /etc/apache2/sites-enabled/000-default:

    Alias /ww2 /srv/www/my.fqdn.tld

    and the same directive in /etc/apache2/sites-enabled/default-ssl:

    Alias /ww2 /srv/www/my.fqdn.tld

    My problems:

    1 / All the links within the homepage redirect to https for some reason I don’t know about, while I want them to redirect to http (except the wp-admin page).

    2/ As soon as I comment out (like this):
    #Alias /ww2 /srv/www/my.fqdn.tld
    in /etc/apache2/sites-enabled/default-ssl, the page loses all its formatting (too bad I can’t add a screenshot 🙁 ).
    Note that all links still redirect to https, but none of them work anymore, since in disabled the Alias directive.

    I’m lost. Any help would be warmly welcomed 🙂


Viewing 3 replies - 1 through 3 (of 3 total)
  • Thanks, actually I’ve already tried it.
    But since I may have missed something out and you still point me to this plugin again, I decided to give it a new chance…

    So, here’s the thing:

    I activate wordpress-https and go to its settings. I try to check the “Force SSL admin.” box, since that’s all I want. I can’t, because the plugin his hunappy with the FORCE_SSL_ADMIN directive, in wp-config.php, it says (it’s not in wp-config, it’s in /etc/wordpress/config-my.fqdn.tld.php, because of Debian style config., but nevermind). So I comment this directive and check this box.

    ALL the links on the main page still point to https (I don’t want this, I just want wp-admin to point to https).

    If I keep the
    Alias /ww2 /srv/www/my.fqdn.tld
    directive in /etc/apache2/sites-enabled/default-ssl the https links work just fine.

    If I comment it, all of the links (including the link to wp-admin) of course don’t work anymore (as they still point to https for some reason I don’t understand).
    I don’t really see the usefulness of this plugin in my case, to sum it up.

    Oh, yeah, just one positive result, the page keeps all its formatting, even when
    Alias /ww2 /srv/www/my.fqdn.tld
    has been disabled in /etc/apache2/sites-enabled/default-ssl.

    But that’s not really what I expected this plugin to do.

    Any clue, someone?


    For those who may face the same kind of problem, here’s how I solved it.
    Searched for https in my wordpress DB, and changed https to http in the url for a few rows in the wp_options table (for ‘option_id’s siteurl and home).

    Since then, all the links point to normal http.
    With define('FORCE_SSL_ADMIN', true); back in the config file, no need for wordpress-https or any other plugin to still have the link to wp-login (and only this one) point to https (while this plugin certainly works fine).

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘https weirdness’ is closed to new replies.