Support » Networking WordPress » Https redirect loop on mutlisite

  • Hi

    I purchased a wildcard SSL cert and had it installed.
    every time I force the HTTPS on admin and login I get a redirect loop
    whether I add to wp-config or add to htaccess or use WordPress Https plugin i still get redirect loop.
    the only time it works if use Force SSL Exclusively on each page but this does not work on login and admin.

    please can you help

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    How did you force https on admin?

    thels

    (@thels)

    Hi

    I add this
    define(‘FORCE_SSL_ADMIN’, true);
    if ($_SERVER[‘HTTP_X_FORWARDED_PROTO’] == ‘https’)
    $_SERVER[‘HTTPS’]=’on’;
    to wp config
    I have also tried wordpress Https plugin the only way that works if I use the the force page. but if enable admin on this plugin it goes into a loop.

    thanks

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    I would actually edit the site in the DB and change http to http for that domain.

    HuddersfieldH

    (@huddersfield-hosting)

    You only need the first line to make the admin SSL
    define('FORCE_SSL_ADMIN', true);
    Are you using a domain mapping plugin? If so remove the remote login checkbox. (Has solved problem for me in the past)

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    That does it for ALL domains though, HuddersfieldH

    I did it on my store – http://halfelf.org/2014/ssl-for-one-domain-on-multisite/ – but it’s not as obvious as all that.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Https redirect loop on mutlisite’ is closed to new replies.