WordPress HTTPS (SSL)
https plugin issue - admin site redirecting to home page (1 post)

  1. shailesh.deodhar
    Posted 1 year ago #


    We have setup WordPress in Windows 2008 Server, IIS 7. We have following settings in wp-config file.

    define('WP_SITEURL', '');
    define('WP_HOME', ''); is our IP address for external world i.e. internet.

    We have installed https plugin. We have configured it to use specific SSN host ( and have checked Force SSL for admin site. This is internal IP address and this way we are allowing admin site to be accessible over https on internal network.

    We have managed to put on rules in IIS to block traffic to wp-admin virtual folder.

    The site is working fine with above configuration.

    What we want is to enable multisite for WordPress. So we added following in wp-config.php file.

    define('WP_ALLOW_MULTISITE', true);

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', '' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    We then created second blog by name 'test'. So now we have following blogs

    Blog 1

    Blog 2

    To be able to enable multisite feature, we had to disable all plugins (including https) before doring multisite changes. After we were done with it, we enabled all plugins (including https) at network level. SSL host in https plugin settings was then got changed to So we went ahead and updated to for both blogs.

    Now if we are trying to access admin site for any of the blog it is always redirecting to home of first blog. Could you please provide some help.

    Just to highlight, we are using 3.3.6 version of https plugin.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

  • RSS feed for this topic
  • Started 1 year ago by shailesh.deodhar
  • This topic is not resolved
  • WordPress version: 3.6.1