Support » Plugin: Force Login » HTTPS not working

  • Resolved MetalMusicMan

    (@metalmusicman)


    This plugin is great, but if I use it with my site being on HTTPS, I get an “Error, too many redirects” loop.

    Reverting the site fully back to HTTP fixes the issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter MetalMusicMan

    (@metalmusicman)

    Doing some further troubleshooting, this seems to be a conflict with my webhost 1and1’s CDN (which is handled by CloudFlare).

    Any thoughts on why CloudFlare / CDN might cause redirect issues with this?

    I don’t have any issues with your plugin on HTTP, and I don’t have any issues with HTTPS when my CloudFlare CDN is turned on. But for some reason, using all three at once causes a “too many redirects” issue with WordPress.

    Thread Starter MetalMusicMan

    (@metalmusicman)

    Aaaaaand I solved my own problem. Hopefully this is useful to you and/or any users of your plugin in the future 🙂

    1and1’s CloudFlare CDN must have the SSL setting on “Full SSL” to avoid this issue. The default is “Flexible SSL”, which was causing the issues I was having. Huzzah!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘HTTPS not working’ is closed to new replies.