Support » Plugin: Post SMTP Mailer/Email Log » https:// not being added to linked attachments when email form is sent

  • Shanhua

    (@shanhua)


    Hi Yehuda,

    I use Gravity Forms in WordPress to collect trip reports via a form in our intranet. I use Post SMTP and SendGrid to handle the mail. Colleagues fill out the form and then attach their report file to the form. Several people are then alerted by email that a report has been posted. A link to download the report is in the alert email.

    Recently, I have noticed that sometimes, https:// is not being added to the link in the attached report file — and then people who receive the email alert can’t open the file. Instead, they are brought back to the login page of the intranet site. This does not occur with every instance; only sometimes.

    Also, the form entries go into a Gravity View table on the intranet site. There, all the links are whole and do work properly.

    So I think the problem is happening during the sending process somehow.

    Any idea of how I can resolve this, or point me in the right direction? My Post SMTP details are below, and examples of what the links look like:

    Without https://
    https://avrdc.org/wp-content/uploads/2018/08/without-https.jpg

    With https://
    https://avrdc.org/wp-content/uploads/2018/08/with-https.jpg

    Post SMTP details

    HostName: avr.avrdc.org
    OS: Linux avr.avrdc.org 2.6.32-042stab128.2 #1 SMP Thu Mar 22 10:58:36 MSK 2018 x86_64
    PHP: Linux 7.0.30 C
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=Yes, zlib_encode=Yes
    WordPress: 4.9.8 en_US UTF-8
    WordPress Theme: Arras
    WordPress Plugins: Gravity Perks, Gravity Forms, Category Posts Widget, Connections Business Directory, WP E-Signature Business add-ons, WP E-Signature, Easy Theme and Plugin Upgrades, ECWD Custom Fields, ECWD Frontend Event Management, ECWD Import/Export, Event Calendar WD Premium, GP Unique ID, Gravity Forms Upload Rules, Gravity Forms Signature Add-on by ApproveMe, GravityView – Gravity Forms Import Entries, GravityView, Inline Google Spreadsheet Viewer, Members Only, Members, Page and Post Lister, Post SMTP, Quiz Cat Business, Rotating Tweets (Twitter widget & shortcode), WD manager, WP Fastest Cache, WP-Filebase Pro, WP Users Exporter
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email
    Postman: 1.9.4
    Postman Sender Domain (Envelope|Message): worldveg.org | worldveg.org
    Postman Prevent Message Sender Override (Email|Name): No | No
    Postman Active Transport: SendGrid API (https://api.sendgrid.com:443)
    Postman Active Transport Status (Ready|Connected): Yes | Yes
    Postman Deliveries (Success|Fail): 4781 | 14
    Postman TCP Timeout (Connection|Read): 20 | 60

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author yehudah

    (@yehudah)

    I will try to check and update.

    Did you resolve this? I am having the same problem and I also use along with Sendgrid.

    The links creating by Sendgrid are very long and prior to update would start with https, now they are http.

    and the links also land on my BLOG home and not the correct URL.

    after disabling postman smtp, I have no trouble with the links.

    Hi pwiard,

    It seems to be a two-step process.

    1) You need to “brand your links”. See the first response from SendGrid below for details and a link to instructions.

    2) Then, under “Settings > Tracking” in your SendGrid account, you need to turn “click tracking” OFF.

    That worked for me. The SendGrid team was very helpful.

    FIRST RESPONSE FROM SENDGRID

    Hi there,
    Thank you for reaching Sendgrid support. My name is Alex and it would be my pleasure to assist you.

    I have checked your concern and I would recommend branding your links. Here you can find more details about this process and how you can set it up: https://sendgrid.com/docs/User_Guide/Settings/Sender_authentication/How_to_set_up_link_branding.html

    Please let me know if you need any further assistance.
    Best regards,
    Alex Ro.
    Technical Support Engineer

    SECOND RESPONSE FROM SENDGRID

    Thanks for providing this information! I was able to see that the link does not correctly download the Test file directly from the email! Would you mind answering the following questions so I can see if this is part of an issue affecting other customers as well?

    Which plugin was actually used to create the message? i.e. Woo Commerce, Gravity Forms, Mail Poet, Ninja Forms, etc.

    Are you using a WordPress site?

    Could you please list of any additional plugins installed on your WP integration if you are using WP?

    Have you tried turning click tracking off and making a test send?

    When sending only with WP and SendGrid and click tracking enabled, does this still occur?

    Thank you!
    Best,
    Danielle

    Plugin Author yehudah

    (@yehudah)

    Thank you @shanhua

    I’m sure it will help a lot of users.

    Thank you. Very much appreciated.

    The SendGrid link has changed after they’ve updated their site.
    For anyone else interested, the correct link is:

    https://sendgrid.com/docs/ui/account-and-settings/how-to-set-up-link-branding/

    thanks again, already figured that out by searching their support. Set it up and things look like they are working again.

    Take care.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘https:// not being added to linked attachments when email form is sent’ is closed to new replies.