Support » Plugin: Broken Link Checker » https links are shown as broken why (also in version 1.11.2)

  • hheckner

    (@hheckner)


    Hi,

    I use 1.11.2 on my local site (not wordpress.com). I have several blog posts which link to https://www.agreedo.com/

    The link checker reports broken links as follows:

    ink last checked: November 20, 2016
    HTTP code: 0
    Response time: 0.000 seconds
    Final URL: https://www.agreedo.com/
    Redirect count: 0
    Instance count: 1

    This link has failed 1 time.
    This link has been broken for 20 minutes.
    Log: === (No response) ===

    (Using Snoopy)
    Link is broken.

    I wonder why. The link is perfectly ok, or do I overlook something?
    Does link checker work well with https links?

    best regards
    Hannes

Viewing 13 replies - 1 through 13 (of 13 total)
  • This still seems to be an issue, it even goes for internal links. Any updates on this?

    I found a problem with links to Oxford Dictionary such as https://en.oxforddictionaries.com/definition/anyword.
    Is this because the call to that URL is from a machine program and not a browser? i.e Is the request to link to that page rejected because it is not from a human?

    I have done yesterday an http to https migration on my website and i have the same problem.

    I have the same details than hheckner and i’ll add this he hasn’t given :

    Journal: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol [Error #35]

    • This reply was modified 10 months, 2 weeks ago by  Ervael. Reason: add journal detail error
    Josh

    (@josheprovoedu)

    We are having this same issue. We switched over to HTTPS and now all my links are showing up broken when they are not.

    Josh

    (@josheprovoedu)

    Greetings!

    I found a solution to our problem, and I hope it will also help you.

    Since we are HTTPS everywhere and we no longer allow HTTP traffic. we actually just redirected over to HTTPS. by default this plugin uses a basic http API(I’m not actually sure what one) to check links. If you are switching to 100% https you’ll want to go disable that.

    To disable that API you will go into the broken link checker settings > Protocols & APIs tab > uncheck the box that says Basic HTTP. Then his save.

    This solved our problem and I hope it solves yours aswell.

    Thanks

    Thanks Josh for this tips. But there is a problem with this solution. I think that if you disable this API, the plugin won’t check external http links you can have in some articles or pages :/

    Josh

    (@josheprovoedu)

    It should still continue to check those HTTP requests if you use one of the other APIs. the difference is that Youtubes API for example is checking both protocols where as the basic http API is only checking http.

    I tested this by going through links on my site that are external http links and having them rechecked. they are still coming back as 200 OK

    Ok that’s seems nice, i’m going to test, thanks you 🙂

    Finally it’s what i supposed, if we disable the http API the plugin don’t verify internal and external links. So the problem isn’t solved.

    Having the exact same issue. Just switched over to https and yup, all my links are now broken.

    Is the plugin creator still checking this forum??

    Josh.biz

    (@joshbiz)

    Same problem… https switch and loads of broken (but not actually broken) links reported.

    Josh

    (@josheprovoedu)

    I noticed that once I activated the curl mod in apache everything started working again for me.

    Josh.biz

    (@joshbiz)

    Thanks for your idea, Josh. Will check that out.

    I noticed that out of around 20 SSL HTTPS websites using Link Checker, only 4 of them were showing the symptoms (multiple broken links, not actually broken).

    On each of the four websites, I tried running the ‘nuclear option’ for rechecking:

    1. Settings > Link checker
    2. Advanced tab: Forced recheck – Re-check all pages

    This has cleared all the incorrectly reported broken links and resolved the issue. Could be just temporary but I’ll recheck again in a weeks time. So for now, I’m happy. 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘https links are shown as broken why (also in version 1.11.2)’ is closed to new replies.