Support » Fixing WordPress » https Blues

  • WP 4.9.4
    bbPress 2.5.14-6684
    Suffusion 4.4.9 Child Theme

    Alluvasudden outta nowhere last week, my forums site was “protected” by https. This change broke the header image (now substituted by all-caps text reading “Research and Revival of Pre-Digital Typefaces.”

    Furthermore, it zapped the sidebar and “uglied up” the top navigation links with an unintended tab effect.

    Until now, I have managed to fix this mess multiple times by adjusting theme settings. Today, it happened again—and I’m out of ideas!

    A tech rep for my host (bluehost.com) says that they are forbidden to do such a thing without instruction from me. So I’m wondering whether there is an explanation involving WordPress itself—or possibly bbPress?

    BlueHost suggests copying all activity of the past few days, restoring a recent backup and then updating recent posts, image uploads, etc. with the copies.

    The downside is that the same scenario may recur indefinitely… Is there something I can do to STOP it once and for all?

    With profound gratitude for your help, Anna

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Thread Starter Type Historian

    (@type-historian)

    P.S. I have just discovered that this problem affects only the static “home page” of forums.typheritage.com. bbPress topics and standard WP pages display as intended—header, sidebar and top navigation links are okay. Examples:

    http://forums.typeheritage.com/topic/lattice/
    http://forums.typeheritage.com/measurement/

    Crazy, huh?

    forums/typeheritage.com is policed up-one-side-and-down-the-other by very effective firewall and anti-spam plugins—it does not need further “protection.” My final goal is to transfer the https option to a sub-domain storing commercial downloads.

    Can you help me to permanently restore the home page to its intended appearance?

    Thank you again for your guidance, Anna

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    You have a lot of mixed content. Install the plugin “better search replace”. Search for http://forums.typeheritage.com and replace with https://forums.typeheritage.com in all tables. Be sure to backup your database first.

    When done, make sure you clear all caches.

    Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure stylesheet 'http://forums.typeheritage.com/wp-content/plugins/scrollto-top.old/css/scrollto-top-css.php?ver=4ecf0b69893ea18a9998acf85b60a0ab'. This request has been blocked; the content must be served over HTTPS.
    (index):52 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure stylesheet 'http://forums.typeheritage.com/wp-content/uploads/suffusion/custom-styles.css?ver=4.4.9'. This request has been blocked; the content must be served over HTTPS.
    jquery-migrate.min.js?ver=1.4.1:2 JQMIGRATE: Migrate is installed, version 1.4.1
    (index):1 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure script 'http://forums.typeheritage.com/wp-content/plugins/scrollto-top.old/js/jquery.scrollTo-1.4.3-min.js?ver=1.4.3'. This request has been blocked; the content must be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure script 'http://forums.typeheritage.com/wp-content/plugins/scrollto-top.old/js/scrollto-top.js.php?ver=1.2.2'. This request has been blocked; the content must be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure script 'http://forums.typeheritage.com/wp-content/plugins/bbpress-quotes/bbpress-quotes.js?ver=1.0'. This request has been blocked; the content must be served over HTTPS.
    (index):677 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/2015/01/Chapel_Logo.jpg'. This content should also be served over HTTPS.
    (index):999 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/Permanent/Sidebars/Revivals.png'. This content should also be served over HTTPS.
    (index):1004 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/2015/09/flickr-e1442197737535.png'. This content should also be served over HTTPS.
    (index):1020 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/Permanent/Sidebars/Research.png'. This content should also be served over HTTPS.
    (index):1056 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/2015/09/flickr-e1442197737535.png'. This content should also be served over HTTPS.
    (index):1059 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/Permanent/GoudyLeaf-Collapse.png'. This content should also be served over HTTPS.
    (index):1094 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/2015/09/flickr-e1442197737535.png'. This content should also be served over HTTPS.
    (index):1100 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/2015/04/Community.png'. This content should also be served over HTTPS.
    (index):1108 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/Permanent/Important.png'. This content should also be served over HTTPS.
    (index):1111 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/2015/04/Bazaar.png'. This content should also be served over HTTPS.
    (index):1147 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/2015/02/Thank_You.png'. This content should also be served over HTTPS.
    (index):1171 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure image 'http://forums.typeheritage.com/wp-content/uploads/2015/04/Support-THP.jpg'. This content should also be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure script 'http://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit'. This request has been blocked; the content must be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure favicon 'http://forums.typeheritage.com/wp-content/uploads/2017/04/Chapel-Favicon.png'. This request has been blocked; the content must be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure stylesheet 'http://forums.typeheritage.com/wp-content/plugins/scrollto-top.old/css/scrollto-top-css.php?ver=4ecf0b69893ea18a9998acf85b60a0ab'. This request has been blocked; the content must be served over HTTPS.
    (index):1 Mixed Content: The page at 'https://forums.typeheritage.com/' was loaded over HTTPS, but requested an insecure stylesheet 'http://forums.typeheritage.com/wp-content/uploads/suffusion/custom-styles.css?ver=4.4.9'. This request has been blocked; the content must be served over HTTPS.
    Thread Starter Type Historian

    (@type-historian)

    Thank you SO much for trying to help me! I’m a historian—not a web designer, so I don’t understand your suggestion:

    For starters, what is “mixed content”? What do you mean by “all *tables*”?

    Since I want to KILL the https setting for this site, is it wise to redirect everything to it?

    Thank you again for your kindness, Anna

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Why do you want to “kill” the https for the site?

    https does not “protect” your site from spammers/crackers/etc. It encrypts the connection between your site and its users and, these days, is the standard for web connections.

    Your site *should be using* https.

    Thread Starter Type Historian

    (@type-historian)

    Unfortunately, I cannot afford the monthly cost of protecting *all* of my sub-domains with https. My host covers only one for free. At this point, I most need to protect the one that will store my partners’ commercial downloads [bazaar.typeheritage.com]. Maybe when income from this eCommerce site begins to generate income, I can upgrade to “across the board” https.

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Edit: Bluehost supports the free LetsEncrypt.org certificates. Ask them about it!

    So to remove https, you’d use the same plugin but reverse it so you search for https and replace with http. Also check your .htaccess file to make sure it’s not doing a redirect to https from http.

    Thread Starter Type Historian

    (@type-historian)

    I have consulted BlueHost about https. I was told that they support only ONE sub-domain free of charge. I prefer a different one.

    I did not use a plugin to invoke https. It just happened outta nowhere. I installed no plugin that accounts for this crazy thing.

    Will a search/replace plugin fix this problem? I have already installed one called
    Velvet Blues Update URLs: https://wordpress.org/plugins/velvet-blues-update-urls/

    I am truly grateful for your time and effort to help me, Anna

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Velvet Blues should do the same thing as better search replace.

    Thread Starter Type Historian

    (@type-historian)

    I have tried both my existing search/replace plugin and the “better” one that you recommended. I entered ~change https://forums.typeheritage.com to http://typeheritage.com~. Neither worked (no changes made): after clearing the cache, the same display problems persist on the static “home page”: https://forums.typeheritage.com/.

    The next step is to check the .htaccess file. Now my problem is that when I search the bluehost file manager for it, it lists multiple choices and none of them leads to a file with this name. I’m in over my head…

    As an interim workaround, I have added a link labeled “Display Problem?” to the menu above where the header image should be. So far, clicking it leads to a perfectly displayed bbPress topic explaining the situation. Standard WP pages look as expected too—the https is gone:

    http://forums.typeheritage.com/topic/security-blues/

    BTW when arriving at the home page via a google search, when entering the URL in the address dialog or from a link at either of two related sites, it displays correctly WITHOUT the https path in Firefox but not with Chrome.

    Regardless of browser, it looks the same when clicking the link in my original post. Eeeeeeeeeeeeeeeeek!!!

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Both have an option to work in “dry run” mode. Are you sure that box was unchecked?

    Thread Starter Type Historian

    (@type-historian)

    100% sure!

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    I no longer see any errors at http://forums.typeheritage.com

    Thread Starter Type Historian

    (@type-historian)

    Magic? Maybe the search/replace trick worked after all and it took time to do the job.

    You are a PRINCE for holding my hand during this ordeal!!!

    Anna x00x0x0x0x0x0x

    Thread Starter Type Historian

    (@type-historian)

    For The Record…

    The mysterious https mess happened again recently when viewing a post marked “confidential” by bbPress:
    https://wordpress.org/plugins/bbpress-private-replies/

    This time, it was easy to cure it by transitioning to another post or page. Maybe I should report this experience to bbPress, huh?

    Thanks again, Anna

    Thread Starter Type Historian

    (@type-historian)

    The same crazy thing happened again today… I am 99% convinced that the bbPress “confidential” option may have been the problem all along.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘https Blues’ is closed to new replies.