WordPress.org

Forums

[resolved] HTTPS and Absolute Path (17 posts)

  1. Matt_hew
    Member
    Posted 3 years ago #

    I have a private SSL certificate and it's working properly on my eCommerce site, DickeyBub.net, however my page includes other resources which are not secure. I went to WhyNoPadlock.com and found out what items are not secure on that page and it turns out that its a couple of images. I've talked with support from my host and they said I need to change the images from a URL to absolute path, but I also know that WP is URL based.

    I'm a bit confused at this point and was wondering what the next step is. I really hope you can help.

  2. Jorge
    Member
    Posted 3 years ago #

    Have you tried updating the URL from the General Settings within Dashboard?

  3. Matt_hew
    Member
    Posted 3 years ago #

    You mean making it a HTTPS instead of HTTP?

  4. Jorge
    Member
    Posted 3 years ago #

    Yes, especially if you intend to keep the SSL site wide. There are also plugins available that help "force" SSL on visitors site wide.

    I have used the following plugin in the past:
    http://mvied.com/projects/wordpress-https/

    Hope this helps.

  5. Matt_hew
    Member
    Posted 3 years ago #

    Thank you that fixed it!

  6. Jorge
    Member
    Posted 3 years ago #

    No problem, however, I just visited your site, and some content hasn't been SSLed, like the YouTube video, etc. That will cause errors. Make sure iframes, images, scripts, etc. all have HTTPS going on, even if it's from a 3rd party. If the 3rd party doesn't offer HTTPS, then your visitors will get "other resources are not secured" warning from the browser.

  7. Matt_hew
    Member
    Posted 3 years ago #

    How do I secure the youtube video? Or any other resources that are not secure?

  8. Jorge
    Member
    Posted 3 years ago #

    Google/YouTube already have their content SSL'ed.

    For example, the URL

    http://www.youtube.com/watch?v=lzTRDeY9ulo&feature=player_embedded

    Can be embedded securely by adding the S to HTTP

    https://www.youtube.com/watch?v=lzTRDeY9ulo&feature=player_embedded

    I'm not certain about other 3rd party Websites, but anything Google is usually SSL enabled.

  9. Matt_hew
    Member
    Posted 3 years ago #

    What about images that are embed from a url that is on my website. Since I have private SSL can I just change the URL from HTTP to HTTPS and that will fix it.

  10. Matt_hew
    Member
    Posted 3 years ago #

    I am now having a problem with my header. For some reason the header is not showing up and I think it's because the image isn't https, but I don't know how to change it. I've tried re-uploading it, but that didn't quite do it. Any ideas?

    I appreciate the help Jorge. Thanks!

  11. Jorge
    Member
    Posted 3 years ago #

    What's the URL of the image?

  12. Matt_hew
    Member
    Posted 3 years ago #

    this is the header image:
    https://dickeybub.net/wp-content/uploads/2012/07/header_db43.png

    i also have a blank image over top it so that people can click back to the homepage, here it is:
    https://dickeybub.net/wp-content/uploads/2012/07/blank_head.png

    Thanks

  13. Jorge
    Member
    Posted 3 years ago #

    Looks like your CSS is missing a character or two.

    your #header CSS looks like this:

    #header ( background: white url('https://dickeybub.net/wp-content/uploads/2012/07/header_db43.png' no-repeat top center; }

    You're missing a ) character after the URL string.

    EDIT (typo and here's the right string):

    #header ( background: white url('https://dickeybub.net/wp-content/uploads/2012/07/header_db43.png') no-repeat top center; }

  14. Matt_hew
    Member
    Posted 3 years ago #

    Thanks Jorge, I am still a bit confused.
    I found #header in two places, here:

    /* ====================== START MAIN STRUCTURE ====================== */
    /* ==== Widths, heights, floats and margins of all basic sections === */
    #header     {  }
    #logo       {  }
    #nav        {  }
    #slogan     {  }
    #slider     { margin-bottom:20px; }
    #content    { width: 75%; }
    #sidebar    { width: 22%; }
    #footer     { clear: both; }

    and here:

    /* ====================== START HEADER ====================== */
    #header { }   
    
    #top{
    	height: 30px;
    	background: #333;
    	position: relative;
    	z-index:10;

    I tried inserting the code you gave in both places, but neither worked. Both of those I found in my style.css in wordpress.

  15. Jorge
    Member
    Posted 3 years ago #

    It's not in your style.css file. It is in the source of your page, do a right-click and "view source". You'll find what I'm talking about in there.

    On Line 57:
    #header { background:#fff url('https://dickeybub.net/wp-content/uploads/2012/07/header_db43.png' no-repeat top center; }

    I'm not sure if you're running a plugin that adds that to the source or if that's part of your theme structure so I can't tell you if you exactly where to edit the CSS.

    Hope this helps.

  16. Matt_hew
    Member
    Posted 3 years ago #

    I've never used 'view source' before. When I did it my line 57 was different. Do I change the code in there or what does that do for me?
    Thanks for having patience with me.

  17. Matt_hew
    Member
    Posted 3 years ago #

    I believe I fixed it. I just change HTTP to HTTPS on the header image file

Topic Closed

This topic has been closed to new replies.

About this Topic