[resolved] HTTPS A SINGLE STATIC PAGE? (7 posts)

  1. dicedtomatoe
    Posted 7 years ago #

    For the life of me I can't figure out how to get WordPress to work with HTTPS. I want to make a single page secure, but when I do that with the SSL Admin plugin my browser goes into a redirect error. Is it possible to make a static page secure in wordpress?

  2. dicedtomatoe
    Posted 7 years ago #

    I figured it out!! Finally!!
    I do believe it is a media temple thing, but at least I figured it out. In the wp-includes/cononial.php file you have to change 'HOST_NAME' to 'SERVER_NAME' on line 48.

  3. mccormicky
    Posted 7 years ago #

    diced:this information is just odd.there is no line in canonical.php(I think this is what you mean by cononial)Host_name or Server_Name on line 48 in the referenced file.
    here is the block I believe you are talking about:

    if ( !$requested_url ) {
    		// build the URL in the address bar
    		$requested_url  = ( !empty($_SERVER['HTTPS'] ) && strtolower($_SERVER['HTTPS']) == 'on' ) ? 'https://' : 'http://';
    		$requested_url .= $_SERVER['HTTP_HOST'];
    		$requested_url .= $_SERVER['REQUEST_URI'];

    So where in this would I make your changes?

  4. scanreg
    Posted 7 years ago #

    Did this work?

    There is some content that I'd like to force SSL on


  5. mccormicky
    Posted 7 years ago #

    I am successfully securing just one page on a website:
    with a private SSL certificate.
    I secured this page by pasting /shop/check-out/ in the Additional URLs box of Admin SSL plugin options page.
    You can get this plugin here:

    This plugin is awesome please donate!

  6. jonahcoyote
    Posted 7 years ago #

    That worked beautifully for me mccormicky! Thanks!

  7. Drew Baker
    Posted 6 years ago #

    I think this might have been your problem. Yes it's a mediatemple thing:

Topic Closed

This topic has been closed to new replies.

About this Topic