Support » Plugin: Gianism » httpsの時だけFacebookでログインエラー

  • Resolved 73kihara

    (@73kihara)


    プラグイン”Gianism”でFacebookとTwitterでのログイン機能を実装中です。

    テスト環境(http)では問題なかったのですが、本番環境(https)に反映するとFacebookログインの方で「Error validating verification code. Please make sure your redirect_uri is identical to the one you used in the OAuth dialog request」というエラーが表示されてしまいました。

    その後アプリ側で製品を追加、「Facebookログイン」を設定してみたところ「URLを読み込めません: このURLのドメインはアプリのドメインに含まれていません。このURLを読み込むには、アプリ設定のアプリドメインにすべてのドメインとサブドメインを追加してください。」というエラーが表示されるようになりました。

    試しに本番環境のSSL設定を解除(WordPressのURLやwp-config、htaccess等)してみたところ正常に動作しました。(この時製品を追加「Facebookログイン」は未設定の状態です)
    httpでは動作しているためプラグインやアプリの設定は間違いないと思うのですが、SSLの設定によって問題が起こっているのでしょうか。

    ちなみ
    さくらのレンタルサーバ プレミアム
    SSLの種類はSNIとなっています。

    また、htaccessとwp-configに下記のような設定をしています。
    https://webtatan.com/blog/wordpress/wordpress-https-sakura

    原因など思い当たることがありましたらご教授頂ければ幸いです。
    よろしくお願いいたします。

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Takahashi Fumiki

    (@takahashi_fumiki)

    おそらく、SSLの設定に不備があるためだとおもわれます。

    実際に帰って来た時のURLがhttpになっていたり、facebookに報告した「ここに戻してね」というURLがhttpになっていたりなどが考えられます。

    SSLを無効にすると動作するということから、WordPressが自身のURLをhttpsと認識していないことが原因かと。

    さくらには公式プラグインがあるようなので、そちらを試してみるのはどうでしょう。

    https://help.sakura.ad.jp/hc/ja/articles/115000047641–WordPress-%E5%B8%B8%E6%99%82SSL%E5%8C%96%E3%83%97%E3%83%A9%E3%82%B0%E3%82%A4%E3%83%B3%E3%81%AE%E4%BD%BF%E3%81%84%E6%96%B9

    73kihara

    (@73kihara)

    ご回答ありがとうございます。
    さくらのプラグインも試してみましたが、同じエラーが発生しております。。。

    一旦プラグインは無効にして、元の状態に戻して調査しております。
    htaccessとwp-configはそれぞれ下記のような設定が入っております。

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Sakura-Forwarded-For} ^$
    RewriteRule ^(.*)$ https://xxxxx.com/$1 [R=301,L]
    </IfModule>
    if( isset($_SERVER['HTTP_X_SAKURA_FORWARDED_FOR']) ) {
        $_SERVER['HTTPS'] = 'on';
        $_ENV['HTTPS'] = 'on';
    }

    やはりリダイレクト時にhttpで戻ってきていることが原因、という可能性が高そうです。
    プラグインとは直接関わりがない内容で申し訳ありません。

    もし他に何か情報がありましたらご教授頂けると幸いです。

    Plugin Author Takahashi Fumiki

    (@takahashi_fumiki)

    Facebookのアプリページで登録しているリダイレクトURLが http になっているとか、そういう可能性はありませんか? 正しく動いているサイトでは、こんな感じの設定になっています。

    https://www.dropbox.com/s/lkdr9vbj9yowcg9/hametuha.png?dl=0。

    73kihara

    (@73kihara)

    ポート番号を設定したところ解決しました。
    色々とご回答ありがとうございました。

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.