Support » Localhost Installs » http://localhost prompts to download localhost

  • I have WAMP installed, and whenever I go to http;//localhost or [127.0.0.1] I get a message in IE and also in Firefox asking if I want to download localhost ot in the case of 127.0.0.1, 127.0.0.1

    [localhost] works fine.

    When I check netstat -a -n -o, the results are 0:0:0:0:80 using PID 6732. Task manager shows PID 6732 as WampApache.

    I just used BackupBuddy to restore a WordPress site form a server to my local machine.

    Here is the contents of localhost when I download/open it:

    <?php
    /**
    * Front to the WordPress application. This file doesn’t do anything, but loads
    * wp-blog-header.php which does and tells WordPress to load the theme.
    *
    * @package WordPress
    */

    /**
    * Tells WordPress to load the WordPress theme and output it.
    *
    * @var bool
    */
    define(‘WP_USE_THEMES’, true);

    /** Loads the WordPress Environment and Template */
    require(‘./wp-blog-header.php’);

    Any ideas?

Viewing 3 replies - 1 through 3 (of 3 total)
  • PHP isn’t running.

    But I can get to http:\\localhost\phpmyadmin and it loads. WAMP is green.

    I’ve searched where to put importbuddy.php to migrate with WAMP, but found nothing.

    Try putting a test php page in your webroot folder which just calls phpinfo() and see if that works.

    If PHP is running you shouldn’t be asked to download index.php

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘http://localhost prompts to download localhost’ is closed to new replies.