Support » Plugin: Add Headers » HTTP_CACHE_CONTROL does not get set

  • Resolved Herbert

    (@herbie4)


    I used the plugin to set Cache-Control: max-age=0 on product pages of woocommerce. That works perfect!

    The only problem is that the $_SERVER[‘HTTP_CACHE_CONTROL’] does not get set.

    1. If I press reload of browser button it does get set.
    But just using the plugin with the max-age=0 it does not.

    2. Tested the server with just a php file with the following:

    header("Cache-Control: max-age=0"); //HTTP 1.1

    That also results in $_SERVER[‘HTTP_CACHE_CONTROL’] => max-age=0

    Any suggestions what to do?

    https://wordpress.org/plugins/add-headers/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Okay, took a different approach to the problem so this question is no longer valid.

    Plugin Author George Notaras

    (@gnotaras)

    Hi Herbert,

    Despite resolving the issue yourself, I’m providing the following sample code to demonstrate the “official” method of doing this, in case others would like to do something similar.

    function addh_no_cache_products ( $options ) {
        if ( is_product() ) {
            $options['cache_max_age_seconds'] = 0;
        }
        return $options;
    }
    add_filter( 'addh_options', 'addh_no_cache_products', 10, 1 );

    George

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘HTTP_CACHE_CONTROL does not get set’ is closed to new replies.