Support » Plugin: WP-Piwik » HTTP/1.1 404 Not Found Error

  • Resolved rtuerz

    (@rtuerz)


    When trying to connect the plugin to my Piwik I get a 404 Not Found error. I know the url is correct. Could this be a problem caused using HTTP2 on the server that Piwik is installed on?

    Here is the error log from the test script:

    WP-Piwik 1.0.15
    Mode: http
    
    Test 1/3: global.getPiwikVersion
    
    bool(false)
    
    array(2) {
      [0]=>
      string(308) "HTTP/1.1 404 Not Found
    Date: Wed, 14 Jun 2017 16:58:41 GMT
    Server: Apache/2.4.25 (Unix) OpenSSL/1.1.0f mod_fcgid/2.3.9
    Vary: accept-language,accept-charset
    Upgrade: h2
    Connection: Upgrade
    Accept-Ranges: bytes
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=utf-8
    Content-Language: en
    
    "
      [1]=>
      string(155) "https://www.home.zgaah.net:915/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&token_auth=..."
    }
    
    Test 2/3: SitesManager.getSitesWithAtLeastViewAccess
    
    bool(false)
    
    array(2) {
      [0]=>
      string(308) "HTTP/1.1 404 Not Found
    Date: Wed, 14 Jun 2017 16:58:42 GMT
    Server: Apache/2.4.25 (Unix) OpenSSL/1.1.0f mod_fcgid/2.3.9
    Vary: accept-language,accept-charset
    Upgrade: h2
    Connection: Upgrade
    Accept-Ranges: bytes
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=utf-8
    Content-Language: en
    
    "
      [1]=>
      string(232) "https://www.home.zgaah.net:915/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&urls[1]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3Dn%2Fa&token_auth=..."
    }
    
    Test 3/3: SitesManager.getSitesIdFromSiteUrl
    
    bool(false)
    
    array(2) {
      [0]=>
      string(308) "HTTP/1.1 404 Not Found
    Date: Wed, 14 Jun 2017 16:58:42 GMT
    Server: Apache/2.4.25 (Unix) OpenSSL/1.1.0f mod_fcgid/2.3.9
    Vary: accept-language,accept-charset
    Upgrade: h2
    Connection: Upgrade
    Accept-Ranges: bytes
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=utf-8
    Content-Language: en
    
    "
      [1]=>
      string(337) "https://www.home.zgaah.net:915/piwik/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3Dn%2Fa&urls[1]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3Dn%2Fa&urls[2]=method%3DSitesManager.getSitesIdFromSiteUrl%26idSite%3Dn%2Fa%26url%3Dhttps%3A%2F%2Fwww.zgaah.net&token_auth=..."
    }
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author braekling

    (@braekling)

    The URL seems not to be correct. If I open https://www.home.zgaah.net:915/piwik/ in my browser, I also get a 404 error.https://www.home.zgaah.net:915/piwik/

    Please check your URL again.

    The URL was fine. I’ve since gone and reformatted my server, and haven’t reinstalled piwik, which is why there’s a 404 now. I figured after a week and a half there wouldn’t be a response. I’ll try the plugin again after I have piwik installed again. If the problem still exists I’ll post again.

    Plugin Author braekling

    (@braekling)

    Well, I’m maintaining this plugin in my free time, beside work and family. I’m sorry for the delay, but responses always may take some time.

    Just tell me if your system is running again. I remember, I called the link shown by your testscript after I received the notification mail, and I’m sure I was not able to open it. But maybe I was already late.

    Server is running again, with the same setup, and I’m running in to the same issue. I’m not going to be changing anything with it, so you won’t have issues of things not being there. Thanks.

    Plugin Author braekling

    (@braekling)

    Seems to be something wrong with your Apache configuration. If I open the URL shown in the test script, I only get the piwik folder’s contents.

    Obviously, your DirectoryIndex does not contain index.php, so I’m able to explore your full Piwik directory structure. You can try to add index.php to your Piwik URL, but I recommend to change your Apache settings… If you publish your directory structure, this also may be a security issue.

    rtuerz

    (@rtuerz)

    I changed the Apache config, and everything works fine. This maybe worth mentioning, the first time I tried to connect the plugin to Piwik after just using the directory url, I tried using the url plus index.php. That also wouldn’t connect.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.