Support » Plugin: bbp style pack » http vs https in email subscription notifications

  • bigskyry

    (@bigskyry59715)


    We had to close a security hole in our site by activating an HSTS protocol in our site header.

    As such, since forum subscription emails contain links that are not HTTPS:// ie:

    http://email2.ourdomain.com/

    Our users can’t click on the link without being blocked by this protocol.

    Can you advise? We need our email links to have the https:// prefix in the URL.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Robin W

    (@robin-w)

    ok, so I’m presuming you have content in

    dashboard>settings>bbp style pack>subscription emails

    yes?

    if so, what have you got in say item 6 and or item 8?

    bigskyry

    (@bigskyry59715)

    Hi Robin,

    Yes, item 6:

    {author} wrote:

    {content}

    Post Link: {url}

    ———–

    You are receiving this email because you subscribed to the {forum_name} forum.

    Login and visit the forum to unsubscribe from these emails.

    ***

    and item 8:

    {author} wrote:

    {content}

    Post Link: {url}

    ———–

    You are receiving this email because you subscribed to a forum topic.

    Login and visit the topic to unsubscribe from these emails.

    Plugin Author Robin W

    (@robin-w)

    thanks – that all looks good.

    what have you got set if anything in item 2?

    bigskyry

    (@bigskyry59715)

    2 is not activated. We use the WordPress login at any rate.

    Plugin Author Robin W

    (@robin-w)

    ok, thanks.

    My code juts uses bbpress url, so bit stumped as to why this is happening.

    Can you

    As a test (you can put it back afterwards) try blanking say the reply message body – make sure it is totally blank. Then the standard bbpress text will take the place, and I can see if my code or bbpress code might be the issue.

    then come back

    bigskyry

    (@bigskyry59715)

    OK, I did that.

    Standard bbpress resulted.

    no change – still http://

    Plugin Author Robin W

    (@robin-w)

    thanks

    hmmm….

    ok as another test, can you deactivate my style pack plugin (again you can re-enable afterwards) , and try again, that should tell us if the problem is with style pack or bbpress/your site.

    bigskyry

    (@bigskyry59715)

    OK, I deactivated it and the issue still exists…

    Plugin Author Robin W

    (@robin-w)

    ok, so it is bbpress/yoursite related

    what is the url in

    dashboard>settings>general>

    WordPress address ?

    and

    site address ?

    bigskyry

    (@bigskyry59715)

    Site address is http://…

    So is that the culprit?

    If so change to https://…?

    Will doing so create any issues?

    Plugin Author Robin W

    (@robin-w)

    both need to match what you site actually is, so if it is https, then that is what should be in the setting

    Not changing will create issues (like this one !)

    bigskyry

    (@bigskyry59715)

    So I changed that but it didn’t resolve the issue.

    Plugin Author Robin W

    (@robin-w)

    ok, not sure what to suggest next.

    bigskyry

    (@bigskyry59715)

    Thanks Robin. Appreciate your help thus far.

    Plugin Author Robin W

    (@robin-w)

    so this is the post link taking you to your site – the bit where you put {url} in the message body in settings – yes ?

    and exactly what does it say – can you give me an example – you can anonymise the site part, but I need to see the rest

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.