Support » Localhost Installs » http to https redirects

  • Hi,

    I migrated my live website to XAMPP using updraft plugin (WP ver 5.9.3). Everything worked fine until I logged out from local host (after migration) and tried to log in again. Now the login page on my local host website redirects me to https at my live URL.

    At my live URL, I use htaccess directions to redirect to https, but I double checked and those were not copied to htaccess file on my local host installation. (I disabled all plugins too)

    My question: how to avoid this redirect on my localhost installation?

    thanks in advance for your time

Viewing 2 replies - 1 through 2 (of 2 total)
  • a2hostingrj

    (@a2hostingrj)

    Did you make sure that WP_HOME and WP_SITEURL are set to addresses that start with http, not https.

    These settings should be located in wp-config.php.

    you may need to change the URL manually in the wp-config.php

    define( 'WP_HOME', 'http://localhost');
    define( 'WP_SITEURL', 'http://localhost');

    this is best explained on this link – https://wordpress.org/support/article/changing-the-site-url/

    • This reply was modified 2 weeks, 3 days ago by kaiph.
    • This reply was modified 2 weeks, 3 days ago by kaiph.
    • This reply was modified 2 weeks, 3 days ago by kaiph.
    • This reply was modified 2 weeks, 3 days ago by kaiph.
    • This reply was modified 2 weeks, 3 days ago by kaiph.
    • This reply was modified 2 weeks, 3 days ago by Steve Stern (sterndata).
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.