Support » Plugin: Really Simple SSL » Http to Https redirection works fine, excepted on homepage

  • Resolved byothe

    (@byothe)


    Hello

    I use Realy Simple SSL and it’s a very nice plugin.
    But I just observed that http to https redirection was working fine on any articles…
    For exemple :
    http://byothe.fr/2021/04/modele-de-processeur-de-mon-pc/

    But it doesn’t work for the homepage : http://byothe.fr

    I tried every options available in the plugin.
    My host is Hostinger and use LiteSpeed servers.

    ———

    General
    Domain: https://byothe.fr
    Plugin version: 4.0.13
    SSL certificate is valid
    SSL is enabled
    
    Options
    * Mixed content fixer
    * htaccess redirect
    
    Server information
    Server: litespeed
    SSL Type: NA
    
    Constants
    No constants defined
    • This topic was modified 6 months, 2 weeks ago by byothe.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    Hi @byothe,

    Did you enable the 301 .htaccess redirect in settings/ssl? That should resolve any redirection issue which might be caused by caching.

    Thread Starter byothe

    (@byothe)

    Hello Rogier,

    I have activated the 301 .htacces redirect…
    ANd the weird thing is redirection work on all articles but not on homepage…

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    Are there any other .htaccess rules in the .htaccess file which might conflict? If possible, please post the .htaccess contents here so I can check it.

    Thread Starter byothe

    (@byothe)

    Here you go 🙂

    # BEGIN LSCACHE
    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
    <IfModule LiteSpeed>
    	RewriteEngine on
    	CacheLookup on
    	RewriteRule .* - [E=Cache-Control:no-autoflush]
    	RewriteRule \.object-cache\.ini - [F,L]
    	
    ### marker CACHE RESOURCE start ###
    	RewriteRule wp-content/.*/[^/]*(responsive|css|js|dynamic|loader|fonts)\.php - [E=cache-control:max-age=3600]
    ### marker CACHE RESOURCE end ###
    	
    ### marker FAVICON start ###
    	RewriteRule favicon\.ico$ - [E=cache-control:max-age=86400]
    ### marker FAVICON end ###
    	
    ### marker DROPQS start ###
    	CacheKeyModify -qs:fbclid
    	CacheKeyModify -qs:gclid
    	CacheKeyModify -qs:utm*
    	CacheKeyModify -qs:_ga
    ### marker DROPQS end ###
    	
    </IfModule>
    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
    # END LSCACHE
    # BEGIN NON_LSCACHE
    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
    ## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
    # END NON_LSCACHE
    
    # BEGIN rlrssslReallySimpleSSL rsssl_version[4.0.13]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
    </IfModule>
    # END rlrssslReallySimpleSSL
    # BEGIN WordPress
    # Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
    # dynamiquement, et doivent ĂȘtre modifiĂ©es uniquement via les filtres WordPress.
    # Toute modification des directives situées entre ces marqueurs sera surchargée.
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    	RewriteBase /
    	RewriteRule ^index\.php$ - [L]
    	RewriteCond %{REQUEST_FILENAME} !-f
    	RewriteCond %{REQUEST_FILENAME} !-d
    	RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # AMPFORWPLBROWSERCSTART Browser Caching
    <IfModule mod_expires.c>
    	ExpiresActive On
    	AddType application/vnd.ms-fontobject .eot
    	AddType application/x-font-ttf .ttf
    	AddType application/x-font-opentype .otf
    	AddType application/x-font-woff .woff
    	AddType image/svg+xml .svg
    	ExpiresByType application/vnd.ms-fontobject "access 1 year"
    	ExpiresByType application/x-font-ttf "access 1 year"
    	ExpiresByType application/x-font-opentype "access 1 year"
    	ExpiresByType application/x-font-woff "access 1 year"
    	ExpiresByType image/svg+xml "access 1 year"
    	ExpiresByType image/webp "access 1 year"
    	ExpiresByType image/gif "access 1 year"
    	ExpiresByType image/jpg "access 1 year"
    	ExpiresByType image/jpeg "access 1 year"
    	ExpiresByType image/png "access 1 year"
    	ExpiresByType image/x-icon "access 1 year"
    	ExpiresByType text/css "access 3 month"
    	ExpiresByType text/javascript "access 3 month"
    	ExpiresByType application/javascript "access 3 month"
    	ExpiresByType application/x-javascript "access 3 month"
    	ExpiresByType application/xhtml-xml "access 3 month"
    	ExpiresByType application/pdf "access 3 month"
    	ExpiresByType application/x-shockwave-flash "access 3 month"
    </IfModule>
    # END Caching AMPFORWPLBROWSERCEND
    Thread Starter byothe

    (@byothe)

    Ok ROgier,

    After a lot of investigation, it appears that it was coming from my CDN cache that was not purging…
    THank you for your help

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    Ah… Thanks for the update.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Http to Https redirection works fine, excepted on homepage’ is closed to new replies.