Support » Fixing WordPress » Http strange problem

  • Hello,
    I have a serious problem with some images. My site is a dropshipping and I have different suppliers that give me a csv to keep update my catalogue. I’m using a plugin to view product images from external urls, so I don’t have to download tons of images on my media library. A supplier of mine use images hosted on an http domain. In the backend they works well, and the link is in http, but in frontend the link of the images are automatically changed in https and they don’t appear. If I manually change the link of the images they works. How I can fix it? There’s a way to force my site to keep the http links of these images?. An exemple is: https://www.eaglemegastore.it/prodotto/console-switch-lite-turchese/, the correct image is: http://datasheet.webhop.net/0000034514.jpg, but in my site automatically correct this link in https://datasheet.webhop.net/0000034514.jpg and don’t works. Please give me an advice, I don’t know how to do!. Thank you!.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • I recommend reaching out to your supplier and having them use SSL, if loading them yourself isn’t an option.

    Chrome will no longer server non-SSL media of any form, and that can seriously hamper shoppers, as you’ve discovered.

    I agree with Rebecca. Aside, Google has made SSL compulsory for all sites. So instead of serving a mixed content, it is better to install SSL cert on site hosting the images. That will solve your problem.

    I also agree that they should use SSL, I already contacted them, but for now they don’t want to change the hosting site. I have to find a solution.

    The only way to make them show is going to be for you to load them yourself, unfortunately, if the company won’t take the simple step of using SSL.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.