Support » Fixing WordPress » HTTP/S Issues After URL Change

  • Resolved saltyoceanwitch

    (@saltyoceanwitch)


    I moved my WordPress site from url1.site to url2.site. For whatever reason it decided it no longer needed the trailing slash after this and would try going to url2.sitewp-admin instead of url2.site/wp-admin – obviously this didn’t work. Fixed this by changing Apache settings to include trailing slash. (????)

    Now, when I try posting or editing posts or pages, it will say Updating failed, you are probably offline. Tried fixing this changing URLs in general settings to https, site then goes into redirect loop.

    I don’t know where to start on this new problem and I’ve been fighting it for 2 weeks, help please?

Viewing 3 replies - 1 through 3 (of 3 total)
  • After changing the domain name, you must also update the Site URL and WordPress URL under Settings > General.

    You should also update the fields WP_HOME and WP_SITEURL in the wp-config.php file.

    define('WP_HOME','https://yoursitename.com');
    define('WP_SITEURL','https://yoursitename.com');

    Finally you should also update the rows where option_name is ‘siteurl’ and ‘home’ in the wp_options table of your database.

    See if these steps fix the issue?

    Thread Starter saltyoceanwitch

    (@saltyoceanwitch)

    I did that already. Like I said, if I change the domain to the HTTPS version of the URL which I want it to be on, it goes into a redirect loop. It works fine on the HTTP version, but I can’t post with the block editor.

    Thread Starter saltyoceanwitch

    (@saltyoceanwitch)

    For anyone else with the same issue, add $_SERVER['HTTPS']='on'; to the wp-config file, apparently.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.